Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Impala Daemon Shutdown and unable to start up

avatar
Expert Contributor

Hi Experts,

 

One of the Impala daemon suddenly went down and we are unable to bring it up.

 

Some queries were executed on the impala daemon.

 

I have captured the logs when it got shutdown.

 

Could not open log file: /var/log/impalad/lineage/impala_lineage_log_1.0-1647629222243
@ 0x95b479 impala::Status::Status()
@ 0xd00b95 impala::SimpleLogger::FlushInternal()
@ 0xd01fcf impala::SimpleLogger::Init()
@ 0xbb9c2a impala::ImpalaServer::InitLineageLogging()
@ 0xbcb25e impala::ImpalaServer::ImpalaServer()
@ 0xbb676d ImpaladMain()
@ 0x8e2593 main
@ 0x7f5cf7658495 __libc_start_main
@ 0x9299e1 (unknown)

 

ERROR cc:312 Aborting Impala Server startup due to failure initializing lineage logging. Impalad exiting.

 

Can some one please tell what steps should be taken, Just to note Enable Audit Collection and Enable Impala Audit Event Generation is enabled/checked.

 

1 ACCEPTED SOLUTION

avatar
Expert Contributor

We are able to bring the impala daemon up by disabling Enable Lineage Collection and Enable Impala Lineage Generation in Impala Configuration and after this the impala queries started resuming fine and the data loads as expected but when I try to enable it back to the previous state it is again going down not sure why it is happening. 

if any one has any suggestions please tell.

View solution in original post

1 REPLY 1

avatar
Expert Contributor

We are able to bring the impala daemon up by disabling Enable Lineage Collection and Enable Impala Lineage Generation in Impala Configuration and after this the impala queries started resuming fine and the data loads as expected but when I try to enable it back to the previous state it is again going down not sure why it is happening. 

if any one has any suggestions please tell.