Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 09-20-2024 09:23 AM - edited 09-20-2024 09:23 AM
Logged SELECT statement targets table with 10736979 rows. What can the reason for this error? Is it related to query timeout? What is the default driver query timeout? prepareStatement has been running for around 3 hours before driver thrown the error.
Caused by: java.sql.SQLException: [Cloudera][ImpalaJDBCDriver](500051) ERROR processing query/statement. Error Code: 0, SQL state: TStatus(statusCode:ERROR_STATUS, sqlState:HY000, errorMessage:Invalid session id: 854422e228b99fe7:8a73e8f716a58fbf
), Query: SELECT `type_enr`, `num_enr`, `num_carte`, `seq_carte`, `type_carte`, `cd_pdt_pilotage`, `code_tarif`, `num_cpt`, `letr_cle`, `numero_personne_host`, `nom_porteur`, `typ_porteur`, `autoris_comerc`, `statu_crt`, `dt_statut`, `dt_saisie`, `dt_vente`, `dt_eche`, `dt_der_fab`, `dt_der_fact`, `code_renouv`, `code_suivi`, `date_suivi`, `nbr_recalcul`, `dt_recalcul`, `nbr_relance`, `dt_relance`, `opt_releve`, `num_dern_rlv`, `matr_vend`, `cd_motif`, `usr_crea`, `trm_crea`, `usr_valid`, `trm_valid`, `usr_maj`, `trm_maj`, `num_lot`, `crt_imp`, `frais`, `origine`, `crt_ppl`, `formule`, `design`, `date_prelv`, `matr_vendeur`, `dt_modif_rec`, `agc_com`, `filler`, `time` FROM `awb_preprod`.`orc_mn_porteur`.
at com.cloudera.impala.hivecommon.api.HS2Client.executeStatementInternal(Unknown Source)
at com.cloudera.impala.hivecommon.api.HS2Client.executeStatement(Unknown Source)
at com.cloudera.impala.hivecommon.dataengine.HiveJDBCNativeQueryExecutor.executeQuery(Unknown Source)
at com.cloudera.impala.hivecommon.dataengine.HiveJDBCNativeQueryExecutor.<init>(Unknown Source)
at com.cloudera.impala.hivecommon.dataengine.HiveJDBCDataEngine.prepare(Unknown Source)
at com.cloudera.impala.jdbc.common.SPreparedStatement.<init>(Unknown Source)
at com.cloudera.impala.jdbc.jdbc41.S41PreparedStatement.<init>(Unknown Source)
at com.cloudera.impa
Created 09-20-2024 09:26 AM
@michalwojtowicz Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our Impala experts @mszurap @ezerihun who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 11-19-2024 05:39 AM
Mentioned error seem to be complaining about expired session which either gets terminated by client or server.
Now, to answer your question driver config has SocketTimeout which controls TCP connection: "The number of seconds that the TCP socket waits for a response from the server before raising an error on the request." and default value of the same is 0(i.e the connection does not time out.)
However, could you confirm whether you have loadbalancer in place for impala through which you are connecting using JDBC driver?
If yes, consider reviewing LB settings which should have timeout configurations allowing server to close the connection for long running queries, for instance:
===
timeout connect
timeout client
timeout server
===