Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Impala SQL Statement Log




I hope this can be answered quickly.  I know there's someone out there that would know this...


I am having an error with Impala because of a non-ascii character(s) in a SQL statement trying to execute in the audit service.


[NavigatorServer-4949170]: Incorrect string value: '\xEF\xBF\xBDCOM...' for column 'OPERATION_TEXT' at row 1


I have fixed this issue before by converting the character set of the target audit table (for example, 

IMPALA_AUDIT_EVENTS_2019_07_19) to utf8mb4.

Also, converted the OPERATION_TEXT column to utf8mb4 character set as well...


The question:

Where can I see the full SQL statement?

NOTE:  The statement in error does not show up in the CM interface for Impala under the Queries tab.




Super Collaborator

@pollard ,

 Based on below doc link: we know that it is recommended to use utf8mb4 character set encoding for MySQL database. And that is what you did to fix the issue.

As far as where to find the query details, have you checked the audits directory on the affected Impala hosts? Usually you will find more details from there.
ls –la /var/log/impala/audit/impala_audit_event_log_xxx

Thanks and hope this helps,


Li Wang, Technical Solution Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum


Hi LiWang,


Yes I have checked the audit logs of Impala.  I ran a grep -i check looking for "OPERATION_TEXT" as a part of a SQL statement that was executed based on the error I was getting in the log and did not find any log entries with that pattern.  I used "ignore case" with grep just to make sure.

Since this is a Navigator record that Impala is trying to insert I tried looking into those logs as well.  Since I don't have permission to look into those logs, I modified the URL in CM's interface so I could see the log content.  Very slow and cumbersome but never found any thing that was very helpful as far as the actual SQL statement that was failing.

Another thing to note is the impala_audit_event_log_1.0-xxx files contain no INSERT statements at all.  It's hard to believe no inserts have happened using Impala at all.  The reason I was looking for an Insert command is my assumption is the error indicated it was trying to insert into the MySQL audit table and was not able to because of the character set issue.

The log that showed the error did not show the whole SQL statement, unfortunately, but I did get a few characters of the offending characters in hex form and the column (OPERATION_TEXT) it we trying to insert into.

Any ideas?



Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.