Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 03-14-2022 08:43 AM
Hello Team,
Our impala services are not starting : its failing with below log file:
Although we have put all configuration file in Impala configuration.
4:18:23.781 PM INFO cc:370
Webserver: set_ssl_option: cannot open /opt/cloudera/security/x509/key/host.pem: error:06065064:digital envelope routines:EVP_DecryptFinal_ex:bad decrypt
4:18:23.782 PM INFO cc:124
Webserver: Could not start on address 0.0.0.0:8007
@ 0xb5e579
@ 0x11e5fec
@ 0x110e053
@ 0xac6b1c
@ 0x7ffa35134554
@ 0xb237e8
4:18:23.782 PM FATAL cc:59
Webserver: Could not start on address 0.0.0.0:8007
Created 03-14-2022 04:36 PM
Hello , In our working machine , it is set under root :
Working :-
[root@elara-master-u2-n02 ~]# getfacl /opt/cloudera/security/x509/key/host.pem
getfacl: Removing leading '/' from absolute path names
# file: opt/cloudera/security/x509/key/host.pem
# owner: root
# group: root
user::rw-
group::r--
other::r--
[root@elara-master-u2-n02 ~]#
Not working :-
[root@elara2-master-u4-n02 83-hdfs-NAMENODE]# getfacl /opt/cloudera/security/x509/key/host.pem
getfacl: Removing leading '/' from absolute path names
# file: opt/cloudera/security/x509/key/host.pem
# owner: root
# group: root
user::rw-
group::r--
other::r--
[root@elara2-master-u4-n02 83-hdfs-NAMENODE]#
Created 03-15-2022 05:32 PM
The issue is resolved . The issue was related to password for Host.pem file
Created 03-14-2022 03:44 PM
@Swagat ,
Please check that the file /opt/cloudera/security/x509/key/host.pem exists and has read permissions for the impala user.
If the file exists, you can grant permission to the impala user by running the following command as root:
setfacl -m user:impala:r-- /opt/cloudera/security/x509/key/host.pem
Cheers,
André
--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Created 03-14-2022 04:36 PM
Hello , In our working machine , it is set under root :
Working :-
[root@elara-master-u2-n02 ~]# getfacl /opt/cloudera/security/x509/key/host.pem
getfacl: Removing leading '/' from absolute path names
# file: opt/cloudera/security/x509/key/host.pem
# owner: root
# group: root
user::rw-
group::r--
other::r--
[root@elara-master-u2-n02 ~]#
Not working :-
[root@elara2-master-u4-n02 83-hdfs-NAMENODE]# getfacl /opt/cloudera/security/x509/key/host.pem
getfacl: Removing leading '/' from absolute path names
# file: opt/cloudera/security/x509/key/host.pem
# owner: root
# group: root
user::rw-
group::r--
other::r--
[root@elara2-master-u4-n02 83-hdfs-NAMENODE]#
Created 03-14-2022 05:04 PM
@Swagat ,
What's the content of your host.pem?
André
Created 03-14-2022 05:07 PM
Its used for SSL certificate.
Created 03-14-2022 06:39 PM
Yep, I know. Would you be able to share the content of that file? You can send it to me in pvt if you prefer.
André
Created 03-15-2022 05:32 PM
The issue is resolved . The issue was related to password for Host.pem file