Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
05-14-2024
07:59 AM
- last edited on
04-20-2026
11:30 PM
by
GrazittiAPI
Hello,
We have a strange issue here.
We are on CDP7.1.9 and have ranger in place for authorizations. A user is trying to execute queries from Hue on Impala Editor and fails with Authorization errors. However, same query works fine via Hive and also via Impala shell. It fails only from Hue editor.
We have:
1. Refreshed metadata
2. Invalidated metadata
3. Verified permissions are in place in Ranger
4. There are no logs generated (I checked in Hue, Sentry Server and Catalog server). Please suggest if any other place should also be checked.
Example query:
select * from DB.table limit 5;
Kindly help to diagnose and resolve this issue.
Created 05-24-2024 04:05 AM
Sssd issue on unix this is resolved
Created 05-15-2024 02:34 AM
Hello @hadoopranger
Do provide the complete error stack trace from hue log and error screenshot from Hue UI to check the same.
Try restarting impala, hue and see if any difference.
Regards,
Chethan YM
Created 05-24-2024 04:05 AM
Sssd issue on unix this is resolved