Support Questions
Find answers, ask questions, and share your expertise

Impala queries through impala JDBC is running with empty user

Super Collaborator

Hi All,


I'm using zeppelin to run report using impala.


I downloaded impala JDBC to my linux machine, when i'm looking at the impala queries at cloudera manager, i see my queries running with empty user " ".


I didn't integrate LDAP authnitication yet with Impala.


I have 2 small questions:


1- where and how i can pass the user that i need the queries to run with in the impala JDBC?


2- How i can restrict only queries qith user specific to run.


Rising Star

You are not using the AuthMech parameter at all.  Perhaps you are not exactly doing what this thread is discussing.  According to the manual, AuthMech should be required.  Regardless, for my use case with Dbeaver I can say for sure that without AuthMech I am not able to connect.


So, one more time...Has anyone successfully connected using AuthMech=2, as described in the manual?

New Contributor

Filed an issue with Cloudera and was confirmed this is a bug. Workaround provided was: 

impala_auth = "AuthMech=3;UseSasl=0", which does not seem to make sense, but worked for me... good luck.

Rising Star

<Sigh>  That did not work for me.  However, someone did suggest just that in this thread I started for Dbeaver:  They were using a password, though.


Just to be absolutely clear, you are using AuthMech=3;UseSasl=0 but no PWD, right?


@xfly, do you have any luck with this syntax?

New Contributor

I did have a password (empty string). I believe you can use anything for username/password with this authmech.

Rising Star

I am very happy to report that this finally did the trick for me.  I had not thought to leave the PWD field blank but that was the answer.


Here is my final connection string that is working perfectly with DBeaver:




@FawzeI think this issue can finally be marked as resolved

View solution in original post

Super Collaborator

@epowell I cann't be happy more than this, after almost 2 years to get this working 🙂

It also works for me . big 3KQ !

New Contributor

Worked for me too. Thank you.