Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Impala query error

avatar
Visitor

Hi,I'm trying to connect the impala on cdp throught JDBC,but it didn't work.It just show:

 

[Cloudera][ImpalaJDBCDriver](500051) ERROR processing query/statement. Error Code: 0, SQL state: Exec() rpc failed: Remote error: Service unavailable: ExecQueryFInstances request on impala.ControlService from 21.97.66.145:38012 dropped due to backpressure. The service queue contains 0 items out of a maximum of 2147483647; memory consumption is 0.
, Query: SELECT 1 as `expr_0`.
java.sql.SQLException: [Cloudera][ImpalaJDBCDriver](500051) ERROR processing query/statement. Error Code: 0, SQL state: Exec() rpc failed: Remote error: Service unavailable: ExecQueryFInstances request on impala.ControlService from 21.97.66.145:38012 dropped due to backpressure. The service queue contains 0 items out of a maximum of 2147483647; memory consumption is 0.
, Query: SELECT 1 as `expr_0`.
at com.cloudera.impala.hivecommon.api.HS2Client.pollForOperationCompletion(Unknown Source) ~[?:?]
at com.cloudera.impala.hivecommon.api.HS2Client.executeStatementInternal(Unknown Source) ~[?:?]
at com.cloudera.impala.hivecommon.api.HS2Client.executeStatement(Unknown Source) ~[?:?]
at com.cloudera.impala.hivecommon.dataengine.HiveJDBCNativeQueryExecutor.executeQuery(Unknown Source) ~[?:?]
at com.cloudera.impala.hivecommon.dataengine.HiveJDBCDSIExtQueryExecutor.execute(Unknown Source) ~[?:?]
at com.cloudera.impala.jdbc.common.SStatement.executeNoParams(Unknown Source) ~[?:?]
at com.cloudera.impala.jdbc.common.BaseStatement.executeQuery(Unknown Source) ~[?:?]
at com.cloudera.impala.hivecommon.jdbc41.Hive41Statement.executeQuery(Unknown Source) ~[?:?]

 

Any help with this impala error is much appreciated.

1 REPLY 1

avatar
Expert Contributor

@WuHua 

Can you please try to add this property and re-run query?

 

 Add
--control_service_queue_mem_limit=200M
to
"Impala Daemon Command Line Argument Advanced Configuration Snippet (Safety Valve)"

 

Thanks !