Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-12-2022 12:41 AM - edited 04-12-2022 12:43 AM
Impala 3.4
When impala-shell is started, impalad.ERROR:
authentication.cc:177] SASL message (Kerberos (external)): GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (No key table entry found for impala@node1)
I don't understand why it got the wrong principal. I passed in the correct principal and keytab in the startup file.
Can someone help me? Thank you very much.
Created 04-12-2022 05:59 AM
Hi,
Can you regenerate the kerberos credentials for impala from CM and see if it helps?
Regards,
Chethan YM
Created 04-25-2022 12:09 AM
Thank you for the attention, I try to regenerate the Kerberos credentials but get the same result. Enable impala in Ambari
Created 04-21-2022 12:44 AM
@ken_zz ,
Please run the following command to list the principals contained in your keytab:
klist -kt <keytab_file>
The full principal name is the long form: either username@REALM or username/fqdn@REALM.
Try specifying the full principal name when starting impala-shell.
Cheers,
André
Created 04-25-2022 12:17 AM
Thank you for the attention, the Principal name is complete and correct.
Impala Catalog and Impala Server will report an error:
9236 authentication.cc:177] SASL message (Kerberos (internal)): GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Server krbtgt/[email protected] not found in Kerberos database)
When I set "-skip_internal_kerberos_auth=true", only Coordinator gets this error.
When I set "-skip_internal_kerberos_auth=true" and "-skip_external_kerberos_auth=true", all components are fine, but then Kerberos authentication is lost.