Support Questions

Find answers, ask questions, and share your expertise

Infrastructure creation issue in GCP with Cloudbreak

New Contributor

I've been having an issue using Cloudbreak 2.4 within GCP to create an HDF cluster.

I'm using a service account that appears to have all of the proper permissions, including the one indicated below in the error. I even went as far as providing the owner role for this service account to over provision permissions. Cloudbreak begins to create the infrastructure, then I get the error below:

Infrastructure creation failed. Reason: Error during status check: [ resourceType: GCP_DISK, resourceName: hdf-test, stackId: 5, operation: hdftest-s-2-20180323123311 ] [ Cause message: 403 Forbidden { "code" : 403, "errors" : [ { "domain" : "global", "message" : "Required 'compute.globalOperations.get' permission for 'projects/*******/global/operations/operation-1521808391647-56813a099af18-300f33eb-8a28c20c'", "reason" : "forbidden" } ], "message" : "Required 'compute.globalOperations.get' permission for 'projects/*******/global/operations/operation-1521808391647-56813a099af18-300f33eb-8a28c20c'" } ]

It would appear that the service account does not have permission to use the disk that is created during the process, hdftest-s-2-20180323123311. Has anyone else run into this problem or have some suggestion of what to look for / how to move forward? I'm simply not sure what I'm missing at this point - it seems quite obvious, but I haven't been able to fix it.




Expert Contributor


We run into the same problem with other resources as well. Even if your service account has Owner role you get this error. We've contacted Google regarding this, but so far we have no answer.

New Contributor

Bummer ... Please let me know if you hear or learn anything and I'll do the same.

Expert Contributor

Hi @Craig Connell

finally we get some response so working on the fix. we will let you know as soon as possible

Expert Contributor


We've upgraded our codebase. Indeed the problem was a minor API change for certain requests. You can upgrade to 2.4.1-rc.27, by downloading the CBD binary

curl -LO$(uname)_x86_64.tgz

Soon we will release 2.4.1, until you can use the rc version.

New Contributor

Thanks for the update - I'll check this out this morning.

New Contributor

The RC version worked. Thanks for the update and the link.



I think google cloud change permission on API global and zone operation.

With operation like "resourceType: GCP_DISK, resourceName: hdf-test, stackId: 5, operation: hdftest-s-2-20180323123311", it run in zone operation. So i see cloudbreak using API globalOperation.get to check this operation, If you using zoneOperation.get to check this it done.



I think google has change permission on API.

For example, with operation "resourceType: GCP_DISK, resourceName: hdf-test, stackId: 5, operation: hdftest-s-2-20180323123311" it run in zone operation, but in cloudbreak we using globalOperation to check status. I has try using zoneOperation to check with operation on zone it done. Please check this!!

Hi @khorvath we tried a cbd update to go from 2.4.0 to 2.4.1 but it didn't work. Is 2.4.1 officially released yet? Not having GCP support at the moment is hurting. Thanks!

Expert Contributor

@Shant Hovsepian

you can not use cbd update but you can update for the patch version as we mentioned.

curl -Ls | sudo tar -xz -C /bin cbd

and then

cbd restart



Thanks Richard! It worked.

Expert Contributor


As Richard said we only haven an RC version so 2.4.1 is not released yet, but hopefully next week you can upgrade simply by calling the cbd upgrade.


Hi, after i update to 2.4.1-rc.27. It has seup cluster on GCS done. I can access Ambari to config, but in Cloudbreak it still show "Update InProcess" (It show in 2 days ago to now). And in detail it show some node not register (But in Ambari it has controlled all node).


And because cluster status in "Update in process", so i can resize. Please fix this, Many Thanks!

Rising Star


@Shant Hovsepian the upgrade couldn't be done by a cbd command because we have only RC release that contains the necessary fix. You could install it by running the following curl command:

curl -LO$(uname)_x86_64.tgz

@Huy Duong Cloudbreak manages Ambari and all of the cloud resources. In your case something went wrong at the orchestration or the Ambari cluster installation phase. This also could happen if you modify something config manually instead of waiting for Cloudbreak to install something.

For any investigation the logs and the event history would be necessary, but it is definitely not related to the changes of Google APIs.

You can now use cbd update to upgrade to 2.4.1. See Cloudbreak 2.4.1 docs.