Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Hi!
I am testing the integration between Cloudera Manager and HSM .
For that purpose I have deployed a singe node cluster in my lab. It consists of two virtual machines implemented in VMware: one manager and one host.
Getting and error trying to complete Installing Cloudera Navigator Key HSM.
Here are the steps I took:
1. mkdir -p /var/www/html/cloudera-repos/cm7
2. wget https://xxxxxx:[email protected]/p/cm7/7.13.1.0/repo-as-tarball/cm7.13.1.0-redhat8.tar.gz -P /var/www/html/cloudera-repos/cm7/
3. tar xvfz /var/www/html/cloudera-repos/cm7/cm7.13.1.0-redhat8.tar.gz -C /var/www/html/cloudera-repos/cm7 --strip-components=1
4. sudo chmod -R ugo+rX /var/www/html/cloudera-repos/cm7
5. In another ssh session, start a Python http.server in the /var/www/html directory.
6. Through vSphere launch a WEB console.
7. Launch the browser and go to https://localhost:8900/cloudera-repos/ and verify the extracted files are present. Checked OK.
8. cat /etc/yum.repos.d/cloudera-repo.repo
[cloudera-repo]
name=cloudera-repo
baseurl=http://localhost:8900/cloudera-repos/cm7
enabled=1
gpgcheck=0
9. sudo rpm --import http://localhost:8900/cloudera-repos/cm7/RPM-GPG-KEY-cloudera
10. sudo yum install keytrustee-keyhsm
Updating Subscription Management repositories.
cloudera-repo 22 MB/s | 151 kB 00:00
No match for argument: keytrustee-keyhsm
Error: Unable to find a match: keytrustee-keyhsm
Any ideas?
Dalier.
Created 08-26-2025 07:01 AM
Thanks!
# yum install /var/www/html/cloudera-repos/cm7/keytrustee-keyhsm-7.1.7.7.1.9.1000-103.x86_64.rpm
Updating Subscription Management repositories.
...
Installed:
keytrustee-keyhsm-7.1.7.7.1.9.1000-103.x86_64
Complete!
Created 08-25-2025 09:34 PM
@Dalier
Thank you for reaching out to the Cloudera community.
Key Trustee Server and Key HSM depend on the bigtop-utils package, which is included in the CDH repository. But you have created the local repository for Cloudera manager.
If Cloudera manager is installed already on both the VM's.Please create a local repository for keytrustee-keyhsm.
https://archive.cloudera.com/p/cdh7/7.1.9.1000/keytrustee-keyhsm/
Created 08-26-2025 07:01 AM
Thanks!
# yum install /var/www/html/cloudera-repos/cm7/keytrustee-keyhsm-7.1.7.7.1.9.1000-103.x86_64.rpm
Updating Subscription Management repositories.
...
Installed:
keytrustee-keyhsm-7.1.7.7.1.9.1000-103.x86_64
Complete!