Support Questions

Find answers, ask questions, and share your expertise

Is Kerberos pre requisite of Sentry Feature : Column Level Security?

Explorer

Hi, do I need to install or enable kerberos first in my CDH 6.3.x cluster before I can use Sentry Column Level security feature?

1 ACCEPTED SOLUTION

Expert Contributor

@Mondi 

 

It is highly recommended to install kerberos as a prerequisite before using sentry.

  • HiveServer2 and the Hive Metastore (HMS) running with strong authentication. For HiveServer2, strong authentication is either Kerberos or LDAP. For the Hive Metastore, only Kerberos is considered strong authentication (to override, see Securing the Hive Metastore).

Below document mentions the prerequisites in detail:

https://docs.cloudera.com/documentation/enterprise/latest/topics/sg_sentry_before_you_install.html#p...

 

Hope this helps,

Paras

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

View solution in original post

1 REPLY 1

Expert Contributor

@Mondi 

 

It is highly recommended to install kerberos as a prerequisite before using sentry.

  • HiveServer2 and the Hive Metastore (HMS) running with strong authentication. For HiveServer2, strong authentication is either Kerberos or LDAP. For the Hive Metastore, only Kerberos is considered strong authentication (to override, see Securing the Hive Metastore).

Below document mentions the prerequisites in detail:

https://docs.cloudera.com/documentation/enterprise/latest/topics/sg_sentry_before_you_install.html#p...

 

Hope this helps,

Paras

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.