Support Questions
Find answers, ask questions, and share your expertise

Is there an updated ggplot2.SparkR package for Spark 2.0.0?

Super Collaborator

Hi Guys,

I want to use ggplot2 for my SparkR dataframe in Spark 2.0.0. I am installing the package by

devtools::install_github("SKKU-SKT/ggplot2.SparkR")

But this is giving me the following exception:

Error in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]) : 
  namespace ‘SparkR’ 2.0.0 is being loaded, but < 1.6.2 is required
ERROR: lazy loading failed for package ‘ggplot2.SparkR’
* removing ‘/usr/hdp/2.5.0.0-1245/spark2/R/lib/ggplot2.SparkR’

It is for 1.6.2 version, does anyone know the correct github from where I can download and install ggplot2.SparkR package?

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Is there an updated ggplot2.SparkR package for Spark 2.0.0?

Super Collaborator

Never mind, just got this thread https://github.com/SKKU-SKT/ggplot2.SparkR/issues/8. Right now, there is no package yet. Will have to wait then. I switched back to 1.6.2 and above command is working.

View solution in original post

1 REPLY 1

Re: Is there an updated ggplot2.SparkR package for Spark 2.0.0?

Super Collaborator

Never mind, just got this thread https://github.com/SKKU-SKT/ggplot2.SparkR/issues/8. Right now, there is no package yet. Will have to wait then. I switched back to 1.6.2 and above command is working.

View solution in original post