Support Questions
Find answers, ask questions, and share your expertise

Issue in Tez View while running jobs from Hive View

Hi,

Below is the error message:

Error code: 401, message: Unauthorized{"message":"Failed to fetch results by the proxy from url: http://hostname:8088/proxy/application_1463416257413_0058/ws/v2/tez/dagInfo?_=1463494671918&dagID=1&counters=&","status":401,"trace":"
\n
\n
\n
\n
\n 
HTTP ERROR 401 \n 
Problem accessing /ui/ws/v2/tez/dagInfo. Reason:\n 
Access denied for user: yarn 
Powered by Jetty:// ↓ 

When I'm trying to see Graphical View from TEZ view while I'm running the query in Hive View, I'm getting above error in under workflow(Additional Info from Hive), Does anyone have which proxy it's trying to fetch and looking for yarn?

1 ACCEPTED SOLUTION

Accepted Solutions

yarn user does not have access

REASON: Tez view was trying to connect to am over port 8088 and did not have enough privileges to access the am.

SOLUTION:

 <property>
	<name>tez.am.view-acls</name>
	<value>*</value>
	<description>AM view ACLs. This setting enables the specified users or groups to view the status of the AM and all DAGs that run within the AM.</description>
</property>

Now I can see query while executing at the bottom. Issue go fixed.

View solution in original post

5 REPLIES 5

Any update on this issue?

Guru

@Ravi Mutyala

I have seen above URL, even verified with my conf and everything is apt. I guess this related to something different proxy. Because in line it say's "access denied for user: yarn"

yarn user does not have access

REASON: Tez view was trying to connect to am over port 8088 and did not have enough privileges to access the am.

SOLUTION:

 <property>
	<name>tez.am.view-acls</name>
	<value>*</value>
	<description>AM view ACLs. This setting enables the specified users or groups to view the status of the AM and all DAGs that run within the AM.</description>
</property>

Now I can see query while executing at the bottom. Issue go fixed.

View solution in original post

Glad that its resolved :).