Support Questions

Find answers, ask questions, and share your expertise

Issue with API v33 and Python client


Hello everybody, first post here so pardon me if I didn't follow all the rules.


So, I'm trying to deploy a cluster (on a single host) using Ansible and Cloudera's APIs. I have managed to install Cloudera Manager and Cloudera Management Service correctly. Now I'd like to install CDH services on this node, but I have some problems with the errors that the API returns to me. In particular I'm trying to install the services by the means of a clusterTemplate. I've managed to download a cluster template from another cluster I've deployed in the past and I'd like to use this to create a new cluster on this node. Actually I would prefer to create a cluster template from scratch but I was not able to find any useful information to build one.


By the way the problem is, when I call the apis the message I receive in response is


"message" : "The following host(s) are not available: <fully qualified hostname of my node>.


If necessary I'll provide the python code I'm using for calling the apis, but I just copied the code I found on the API's doucmentation. Plus, even if I use a curl to contact the apis I receive the same error.


Also, I'm using a EC2 aws instance for deploying the cluster.


Thanks in advance for your help.


Rising Star

Hello @geralt 

Please confirm the steps followed and the exact command used to import thee cluster template. Also, please share the reference to the documentation you referred to.


Please confirm the CM/CDH version of the cluster from which you downloaded the template and the CM/CDH version of the cluster you are trying to create.


From the host where you are trying to run the import command, try to check if you are able to ping the host which is not available (as per the error).


Also, please share the python code you are using to call the Cloudera's API.


Hello and happy new year! I'm sorry for the delay of my response, but I somehow managed to solve the issue. The fact was that I was trying to import the cluster template on a cluster that was already "initialized". What I think it happened is that during my tests with the cluster template I wrote a malformed json file (which brought to some errors during the installation) but the cluster template install command still managed to create an empty cluster. When I tried again the procedure with the correct cluster template json I didn't think about deleting the cluster and this caused the issue I presented in the post. When I deleted from scratch everything and tried again the procedure it worked.


By the way I followed this documentation