Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Issues when create kafka-connect-mongodb, connection refused


I have 3 nodes in kafka cluster, and need to create connector to stream data to mongodb. so on kafka side, I need to create this connector, seemed it has some issues.

when I run this curl : curl -X POST -H "Content-Type: application/json" --data @/tmp/mongo_connector_configs.json http://localhost:8083/connectors

1. always get connect to localhost:8083 refused, after change to FQDN, still the same error.

2. So cat>>authorized_keys, the error is gone, no errors after execute curl command above.

3. when netstats -tunlp|grep 8083, the output is nothing -- this means 8083 is not listen

4. after I started producer, and enter some doc, I just dont see data insert to mongdb at all.

Dont let mongdb part freak you out, it is all about kafka connector creation.

Can any one help me with this issue? thank you very much.



What is the o/p of this command.

telnet localhost 8083


I got this

telnet localhost 8083,

connect to address Connection refused

please let me know what I can do from here. 8083 is default port for kafka connector, how come it refused connection?

What is the host entries

cat /etc/hosts

What is the ip binded to port.

netstat -tulpn | grep -i 8083


thank you for your time, this is the /etc/hosts file, I have 6 of them

b1 b2 b3


netstat -tulpn | grep -i 8083
output is nothing 
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.