Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

KUDU time sync error

KUDU time sync error

New Contributor

Hi,

 

I have deployed kudu service in My CDH Cluster.

Though chronyd is active in all cluster host am getting time sync issue in kudu 

 

This is what am getting in log

 

Check failed: _s.ok() Bad status: Service unavailable: Cannot initialize clock: Error reading clock. Clock considered unsynchronized

 

can some one suggest me solution to activate kudu

3 REPLIES 3

Re: KUDU time sync error

Explorer

hi @Amritha ,
when you're running the command ntpq -np ,
(ntp should be already installed I guess )
what does it give as result?

greetings .

Re: KUDU time sync error

New Contributor

@Bildervic The "ntpq -np" commands gives me error

-bash: ntpq: command not found

 

But chronyd is active I have checked the status of it

 

chronyd.service - NTP client/server

   Loaded: loaded (/usr/lib/systemd/system/chronyd.service; enabled; vendor preset: enabled)

   Active: active (running) since Fri 2019-08-02 03:03:41 EDT; 1 day 22h ago

     Docs: man:chronyd(8)

           man:chrony.conf(5)

 Main PID: 1474 (chronyd)

   CGroup: /system.slice/docker-d9d5006ce9ac375bcfc928d5cd82657e0e5097b12e234849053c49aecd838217.scope/system.slice/chronyd.service

           └─1474 /usr/sbin/chronyd

 

I have installed chronyd while creating bin. 

Highlighted

Re: KUDU time sync error

Explorer

@Amritha 
as I have checked  some  Kudu  manuals, 

Chrony is not fully tested with KUDU for network time synchronization.


 "Kudu releases are only tested with NTP. Other time synchronization providers like Chrony may or may not work."


so you can either try to install NTP.

or just try this tip I've found :


"In order to use chrony for synchronization (for KUDU), chrony.conf must be configured with the rtcsync option"

good luck