Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Kafka Broker not starting after enabling ranger

avatar
Explorer

Hi Team,

 

After enabling ranger in Kafka, I am not able to bring up the Kafka broker instance.

 

The error is:

[kafka-raft-io-thread]: Encountered fatal fault: Unexpected error in raft IO thread
org.apache.kafka.common.errors.ClusterAuthorizationException: Received cluster authorization error in response InboundResponse(correlationId=0, data=FetchResponseData(throttleTimeMs=0, errorCode=31, sessionId=0, responses=[]), sourceId=155)

 

Please help resolve this. Thanks in advance.

1 ACCEPTED SOLUTION

avatar
Super Collaborator

Hello @amru,

We need the complete log file or a relevant log snippet to understand why Kafka is failing after enabling Ranger.

But you should consider checking,

  • Check Ranger’s audit logs to see if any access requests were denied, which could help you pinpoint the issue and the specific resource where permissions are lacking.
  • You should check the Ranger logs for any errors or issues.
  • Ensure that Kafka policies are synced successfully.
  • If you are using AD/LDAP, ensure that all users are properly synced with Ranger.

Thank you

View solution in original post

3 REPLIES 3

avatar
Explorer

Kafka is depolyed in cloudera

avatar
Community Manager

@amru Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our Kafka experts @Babasaheb @rki_  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:

avatar
Super Collaborator

Hello @amru,

We need the complete log file or a relevant log snippet to understand why Kafka is failing after enabling Ranger.

But you should consider checking,

  • Check Ranger’s audit logs to see if any access requests were denied, which could help you pinpoint the issue and the specific resource where permissions are lacking.
  • You should check the Ranger logs for any errors or issues.
  • Ensure that Kafka policies are synced successfully.
  • If you are using AD/LDAP, ensure that all users are properly synced with Ranger.

Thank you