Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 10-22-2024 07:28 AM
Hi Team,
After enabling ranger in Kafka, I am not able to bring up the Kafka broker instance.
The error is:
[kafka-raft-io-thread]: Encountered fatal fault: Unexpected error in raft IO thread org.apache.kafka.common.errors.ClusterAuthorizationException: Received cluster authorization error in response InboundResponse(correlationId=0, data=FetchResponseData(throttleTimeMs=0, errorCode=31, sessionId=0, responses=[]), sourceId=155) |
Please help resolve this. Thanks in advance.
Created 10-22-2024 11:56 AM
Hello @amru,
We need the complete log file or a relevant log snippet to understand why Kafka is failing after enabling Ranger.
But you should consider checking,
Thank you
Created 10-22-2024 07:29 AM
Kafka is depolyed in cloudera
Created 10-22-2024 10:54 AM
@amru Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our Kafka experts @Babasaheb @rki_ who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 10-22-2024 11:56 AM
Hello @amru,
We need the complete log file or a relevant log snippet to understand why Kafka is failing after enabling Ranger.
But you should consider checking,
Thank you