Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Kafka S3 sink connector failing

avatar
Expert Contributor

We recently upgraded Kafka to 2.3.0 after that one of our connector is failing with the below error. 

 

org.apache.kafka.connect.errors.ConnectException: org.apache.kafka.connect.errors.SchemaProjectorException: Switch between schema-based and schema-less data is not

 

Any ideas anyone ?

I have already looked and implemented this https://issues.redhat.com/browse/DBZ-235 but no luck. 

Nothing has changed in the schema. We dont think its a tombstone issue. I was able to check where the connector stopped and looked at the events and its not a tombstone. 

1 ACCEPTED SOLUTION

avatar
Expert Contributor

I was able to resolve this issue after a lot of work. 

Records in kafka had null values and S3 sink connector cannot write null values to S3 bucket and failed with this error, We were able to dig deeper when we changed the flush.size =1 and then we saw a different error and that made us check for null values. 

 

We developed a patch that fixed the issue. now the S3 connector ignores null values . I dont know why confluent SMT did not work. 

View solution in original post

1 REPLY 1

avatar
Expert Contributor

I was able to resolve this issue after a lot of work. 

Records in kafka had null values and S3 sink connector cannot write null values to S3 bucket and failed with this error, We were able to dig deeper when we changed the flush.size =1 and then we saw a different error and that made us check for null values. 

 

We developed a patch that fixed the issue. now the S3 connector ignores null values . I dont know why confluent SMT did not work.