Support Questions
Find answers, ask questions, and share your expertise

Kerberized HDP 2.4 - Error in upgrading Ambari to 2.2.2

Expert Contributor

Hi All - i'm upgrading Ambari from 2.2.1 to 2.2.2.0, and running into issues while starting ambari-agent.

Pls. note - i'm refering the following link for the upgrade -

http://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_upgrading_Ambari/content/_upgrade_ambari....

----------Error ------------------------------------------------------------------------------------------

[root@sandbox ~]# ambari-agent start Verifying Python version compatibility... Using python /usr/bin/python Checking for previously running Ambari Agent... Starting ambari-agent Verifying ambari-agent process status... ERROR: ambari-agent start failed. For more details, see /var/log/ambari-agent/ambari-agent.out: ==================== Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/ambari_agent/AmbariAgent.py", line 24, in <module> from Controller import AGENT_AUTO_RESTART_EXIT_CODE File "/usr/lib/python2.6/site-packages/ambari_agent/Controller.py", line 44, in <module> from ambari_agent.AlertSchedulerHandler import AlertSchedulerHandler File "/usr/lib/python2.6/site-packages/ambari_agent/AlertSchedulerHandler.py", line 34, in <module> from alerts.script_alert import ScriptAlert File "/usr/lib/python2.6/site-packages/ambari_agent/alerts/script_alert.py", line 27, in <module> from resource_management.libraries.functions.curl_krb_request import KERBEROS_KINIT_TIMER_PARAMETER ImportError: cannot import name KERBEROS_KINIT_TIMER_PARAMETER ==================== Agent out at: /var/log/ambari-agent/ambari-agent.out Agent log at: /var/log/ambari-agent/ambari-agent.log

-----------------------------------------------

Any ideas on how to overcome this error ?

Appreciate your inputs. thanks.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Kerberized HDP 2.4 - Error in upgrading Ambari to 2.2.2

Expert Contributor

the issue is fixed, ambari-server was not upgraded, while the agent was upgraded - hence the issue.

View solution in original post

1 REPLY 1

Re: Kerberized HDP 2.4 - Error in upgrading Ambari to 2.2.2

Expert Contributor

the issue is fixed, ambari-server was not upgraded, while the agent was upgraded - hence the issue.

View solution in original post