Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Knox LDAP Integration

New Contributor

We are trying to integrate Knox with LDAP (with SSL). We have a self signed certificate for Knox, certificate for LDAP. We have imported all the certificates that we had in both "/var/lib/knox/data-" and "/etc/pki/java/cacerts" along with the gateway-identity. Still we get the below mentioned error. We tried with both --insecure and without --insecure. For testing purpose, we are trying a basic using command in Webhdfs. It worked fine in test bed with Knox's in-built LDAP (LDAP Demo service) without SSL. But couldn't resolve to any in the current one. Struck for more than a week.

FYI - ldapwhoami command works flawlessly from the same node.

1. Is there any way to disable SSL and check as a first step ?

2.What are we missing ?

Please help.

Thank you.

Adharsh Krishnan Sennimalai



Were you able to resolve this? Any error is knox gateway logs?

New Contributor

try -iv - k -u

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.