Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on 04-14-2019 08:48 PM - edited 09-16-2022 07:18 AM
Hi Guys,
I am trying to sync ldap users, I am getting below error, any idea, please?
====================
Review Settings
====================
Primary LDAP Host : xxxxxxxxxxxxx001
Primary LDAP Port (636): 636
Secondary LDAP Host <Optional>: xxxxxxxxxxx002
Secondary LDAP Port <Optional> (636): 636
Use SSL [true/false] (true): true
User object class (posixUser): posixUser
User ID attribute (uid): uid
Group object class (posixGroup): posixGroup
Group name attribute (cn): cn
Group member attribute (memberUid): memberUid
Distinguished name attribute (dn): dn
Search Base (dc=xyzcompany,dc=com): dc=xyzcompany,dc=com
Referral method [follow/ignore] (follow): follow
Bind anonymously [true/false] (false): false
Handling behavior for username collisions [convert/skip] for LDAP sync (skip): skip
Force lower-case user names [true/false] (true): true
Results from LDAP are paginated when requested [true/false] (false): false
ambari.ldap.connectivity.bind_dn: uid=svcTDPlookup,ou=serviceaccounts,ou=users,dc=xyzcompany,dc=com
ambari.ldap.connectivity.bind_password: *****
ambari.ldap.advanced.disable_endpoint_identification: false
ssl.trustStore.type: jks
ssl.trustStore.path: /etc/ambari-server/keys/ldaps-keystore.jks
ssl.trustStore.password: *****
Save settings [y/n] (y)?
Saving LDAP properties...
Saving LDAP properties finished
Ambari Server 'setup-ldap' completed successfully.
[root@shldvgdka001 keys]# ambari-server restart
Using python /usr/bin/python
Restarting ambari-server
Fetching LDAP configuration from DB.
Syncing specified users and groups...ERROR: Exiting with exit code 1.
REASON: Caught exception running LDAP sync. XXXXXXXXX02:636; nested exception is javax.naming.CommunicationException: XXXXXXXXXXX002:636 [Root exception is java.net.SocketException: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.SSLContextImpl$DefaultSSLContext)]
Created 04-15-2019 04:47 AM
It seems to be an SSL issue can you validate your LDAP, the port 636 is LDAPS and 389 is for LDAP.
To enable LDAPS, you must install a certificate that meets the following requirements:
Hope that helps
Created 04-15-2019 04:47 AM
It seems to be an SSL issue can you validate your LDAP, the port 636 is LDAPS and 389 is for LDAP.
To enable LDAPS, you must install a certificate that meets the following requirements:
Hope that helps