Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

LLAP daemon exception when running hive query..



I'm running an INSERT INTO hive query into a transactional table through beeline with execution.mode=LLAP. When I run the query twice in a row it completes successfully. But when I run it for a third time I get the following output indicating (No LLAP daemons are running):


Looking back in to ambari I see an issue reported from hive for the LLAP Application: The application reported a 'NOT RUNNING' state.

So it seems after running the simple insert query a few times, it crashes LLAP application daemon. Is this a known issue?

Only LLAP related issue in the hiveserverinteractive.log are the following lines:

2017-01-25T10:56:30,394 WARN  [HiveServer2-Handler-Pool: Thread-90]: conf.HiveConf ( - HiveConf of name hive.llap.daemon.allow.permanent.fns does not exist2017-01-25T10:56:30,394 WARN  [HiveServer2-Handler-Pool: Thread-90]: conf.HiveConf ( - HiveConf hive.llap.daemon.vcpus.per.instance expects INT type value





just for further hive.llap.daemon.vcpus.per.instance is set to ${hive.llap.daemon.num.executors} in ambari. hive.llap.daemon.num.executors = 1.

Each node in the cluster is configured to have 4 vCores. Could this cause problems?


The applocation logs for LLAP YARN app might have some errors indicating why it has failed.

Super Guru

can you try making the configuration changes identified in this HCC post:

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.