Support Questions
Find answers, ask questions, and share your expertise

Local repository HDP installation error

New Contributor

I am trying to install some Ambari services from a server which also contains the local repository of all the packages to 2 slaves and when I try to install using the web interface of Ambari server I get the following error and it fails for both slaves.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/datanode.py", line 174, in <module>
    DataNode().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/common-services/HDFS/2.1.0.2.0/package/scripts/datanode.py", line 49, in install
    self.install_packages(env)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 567, in install_packages
    retry_count=agent_stack_retry_count)
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155, in __init__
    self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 160, in run
    self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 124, in run_action
    provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 54, in action_install
    self.install_package(package_name, self.resource.use_repos, self.resource.skip_repos)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/yumrpm.py", line 49, in install_package
    self.checked_call_with_retries(cmd, sudo=True, logoutput=self.get_logoutput())
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 83, in checked_call_with_retries
    return self._call_with_retries(cmd, is_checked=True, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py", line 91, in _call_with_retries
    code, out = func(cmd, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 71, in inner
    result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 93, in checked_call
    tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 141, in _call_wrapper
    result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 294, in _call
    raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/usr/bin/yum -d 0 -e 0 -y install hadoop_2_5_0_0_1245-client' returned 1. There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
Error: Package: hadoop_2_5_0_0_1245-client-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
           Requires: hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
           Available: hadoop_2_5_0_0_1245-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
               hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
Error: Package: hadoop_2_5_0_0_1245-yarn-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
           Requires: hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
           Available: hadoop_2_5_0_0_1245-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
               hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
Error: Package: hadoop_2_5_0_0_1245-hdfs-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
           Requires: hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
           Available: hadoop_2_5_0_0_1245-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
               hadoop_2_5_0_0_1245 = 2.7.3.2.5.0.0-1245.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
1 REPLY 1

Expert Contributor
  • Error:Package: hadoop_2_5_0_0_1245-hdfs-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
  • Requires: hadoop_2_5_0_0_1245 =2.7.3.2.5.0.0-1245.el6
  • Available: hadoop_2_5_0_0_1245-2.7.3.2.5.0.0-1245.el6.x86_64 (HDP-2.5)
  • hadoop_2_5_0_0_1245 =2.7.3.2.5.0.0-1245.el6
  • You could tryusing--skip-broken to work around the problem
  • You could try running: rpm -Va--nofiles --nodigest
  • --It required/touch depended package during the installation of packages.

    --Setup CentOS repo file, then proceed to install HDP.

    yum repolist