Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Localhost:1080 refused to connect - Hortonworks Sandbox HDP

New Contributor

Hi there!


I run Hortonworks Sandbox HDP in VMware and Virtualbox for Windows.

Ram requirements to run it in virtual machine are 10GB. My laptop has just 8GB Ram.

I run it with 8GB. I become the localhost direction to connect with the browser:


But when I go to the browser the browser refuse to connect to this address.


I configured the network with Host-only adapter but it dint work for both Virtualbox and VMWare.

In Virtualbox adding one networking more; "bridge" it works,

In VMWare it worked adding another networkconfig: NAT.

Both provide me with the addres for the browser  http://localhost:1080,

But the browser refuse to connect to it.


How can I solve it? Its an issue the RAM requirements? cause the Virtual machine run anyway.


Thanks in advanced for your views on that



@BlueShangai First, HDP is very out dated, i recommend alternative and newer toolsets.  That said,  in my previous experience with this sandbox, even a 16gb machine struggles to deploy the entire cluster.  If it does, there will be stability issues with 1 or more components.  When i used a 32gb machine, the stack come sup and is much better stable sandbox.  However, this HDP Sandbox is a gaint stack of services that is designed for many machines, so use something like this with caution.