Support Questions
Find answers, ask questions, and share your expertise

Metron rest start-up

Metron rest start-up

Hi ,

I am trying to run Metron using Ambari on Amazon EC2 instance. I downloaded Metron rest and on a metron node and trying to start the process. But I am getting socket errors. Help much appreciated.

19496-socket.png

6 REPLIES 6

Re: Metron rest start-up

Guru

Hello @Rahul P,

If this is Amazon EC2 instance, then please make sure that Hadoop ports (2181 for ZooKeeper, 8020 for NameNode etc.) are white-listed for network traffic. A quick test would be to run zkCli.sh to one of the ZooKeeper like this:

/usr/hdp/2.6.1.0-129/zookeeper/bin/zkCli.sh -server zookeeper-host:2181

Once you get this working, then you can try starting Metron again.

Hope this helps!

Re: Metron rest start-up

Hello @Vipin Rathor sorry for the delay and thanks for the reply. It kinda worked now I am not getting any socket errors but insted getting this :

19520-zk.png

Re: Metron rest start-up

Guru
@Rahul P

This is a step in right direction. Now what you are probably missing is a ZooKeeper quorum configuration, which is why your zkClient is not able to instantiate.

Please follow Metron Rest documentation and provide all these 'required' info in /etc/sysconfig/metron file :

REQUIRED

METRON_JDBC_DRIVER
JDBC driver class

METRON_JDBC_URL
JDBC url

METRON_JDBC_USERNAME
JDBC username

METRON_JDBC_PLATFORM
JDBC platform (one of h2, mysql, postgres, oracle

ZOOKEEPER
Zookeeper quorum (ex. node1:2181,node2:2181)

BROKERLIST
Kafka Broker list (ex. node1:6667,node2:6667)

HDFS_URL
HDFS url or fs.defaultFS Hadoop setting (ex. hdfs://node1:8020)

May I also suggest to use metron-rest init.d script to start Metron Rest service. This way it will take care of some dependencies for you.

Hope this helps.

PS - Please mark a reply as answer if it helped. Thanks.

Re: Metron rest start-up

@Vipin Rathor I did mention zookeeper clients and kafka broker lists in application.yml file

Re: Metron rest start-up

Guru

@Rahul P,

The Metron REST doc says this info to be present in /etc/sysconfig/metron file. I'm not sure if placing the same info in application.yml file would work or not. If I were you, I'd try to create that file as directed and try once. Maybe you should try that too.

Re: Metron rest start-up

@Vipin Rathor

I should have done this long ago. Well this is my application.yml file

server: port: 8082

spring:

datasource:

driverClassName: com.mysql.jdbc.Driver

url: jdbc:mysql://ip-10-0-1-17.ec2.internal:3306/metronrest

username: Admin

password: Admin

jpa:

hibernate:

ddl-auto: update

zookeeper:

url: {ip-10-0-1-17.ec2.internal: 2181}

kafka:

broker:

url: {ip-10-0-1-214.ec2.internal: 6667,ip-10-0-1-234.ec2.internal: 6667}

hdfs:

namenode:

url: {ip-10-0-1-17.ec2.internal: 8020}

grok:

path: temp: ./patterns/temp

default: /apps/metron/patterns

storm:

ui:

url: {ip-10-0-1-17.ec2.internal}

parser:

script.path: /usr/hcp/1.1.0.0-71/metron/bin/start_parser_topology.sh

enrichment: script.path: /usr/hcp/1.1.0.0-71/metron/bin/start_enrichment_topology.sh

indexing: script.path: /usr/hcp/1.1.0.0-71/metron/bin/start_elasticsearch_topology.sh