Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Metron vagrant up failing at ansible step - Amabari client

Solved Go to solution
Highlighted

Metron vagrant up failing at ansible step - Amabari client

Explorer

Here is the error o/p start

TASK [httplib2 : Install python httplib2 dependency] ***************************

changed: [node1]

TASK [ambari_config : include_vars] ********************************************

ok: [node1]

TASK [ambari_config : Install python-requests] *********************************

changed: [node1]

TASK [ambari_config : Deploy cluster with Ambari; http://node1:8080] ***********

fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "Ambari client exception occurred: Coud not get blueprint list: request code 404,

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Rising Star

Sagar is running behind a corporate proxy. He had configured the proxy in both his Mac system settings and global Vagrant settings. When he issued a web request to "node1:8080" or "192.168.x.x:8080" it was going to the proxy server which then redirected him to the "node1.com" web address.

We updated the Mac and Vagrant settings to bypass the proxy for that specific IP address. This resolved the immediate issue. As a follow-on, we need to update those same settings to bypass the proxy for any IP address in the private subnets of 10.0.0.0/8 and 192.168.0.0/16. This should help avoid problems with future deployments of Metron should it choose to grab a different IP address.

He is attempting a fresh deployment with these proxy settings. We are not out of the woods yet, but that's progress at least. @sagar gaikwad, please update us on how the deployment goes.

View solution in original post

16 REPLIES 16
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer

Hi Sagar, can you please attach your ansible.log whenever you get a chance?

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer

Wow, so, looking at that log, it looks like it's trying to go to node1:8080 and it's getting redirected to google (you can see from the logs, the response looks like google results).

What version of vagrant is being used here?

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer

Version: Vagrant 1.7.4

I also noticed that when I try to open node1:8080 via browser is re-routes to googles and opens up www.node1.com

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer

Yeah, I'm running 1.8.1. I would consider upgrading vagrant; looks like it's not setting up that hostname properly.

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Rising Star

For reference, here's the current version list:

@nallen has a PR up with a more complete readme for the Singlenode Vagrant install. Until it gets merged in, you can see it here:

Singlenode Vagrant Readme

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Rising Star

Sagar is running behind a corporate proxy. He had configured the proxy in both his Mac system settings and global Vagrant settings. When he issued a web request to "node1:8080" or "192.168.x.x:8080" it was going to the proxy server which then redirected him to the "node1.com" web address.

We updated the Mac and Vagrant settings to bypass the proxy for that specific IP address. This resolved the immediate issue. As a follow-on, we need to update those same settings to bypass the proxy for any IP address in the private subnets of 10.0.0.0/8 and 192.168.0.0/16. This should help avoid problems with future deployments of Metron should it choose to grab a different IP address.

He is attempting a fresh deployment with these proxy settings. We are not out of the woods yet, but that's progress at least. @sagar gaikwad, please update us on how the deployment goes.

View solution in original post

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Explorer

I modified proxies in vagrant.d folder and was able to get past the initial error. I am now failing for some other error at Elasticsearch step

TASK [elasticsearch : Add Elasticsearch GPG key.] ******************************

fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "Failed to validate the SSL certificate for packages.elastic.co:443. Make sure your managed systems have a valid CA certificate installed. If the website serving the url uses SNI you need python >= 2.7.9 on your managed machine. You can use validate_certs=False if you do not need to confirm the server\\s identity but this is unsafe and not recommended Paths checked for this platform: /etc/ssl/certs, /etc/pki/ca-trust/extracted/pem, /etc/pki/tls/certs, /usr/share/ca-certificates/cacert.org, /etc/ansible"}

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Did u get the required output?what steps did u follow for that?

Don't have an account?
Coming from Hortonworks? Activate your account here