Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Metron vagrant up failing at ansible step - Amabari client

Solved Go to solution
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

I had a single-node vagrant step completely lock up my macbook pro, had to reboot it. Vagrant 1.8.1. Froze on the ambari deploy step.

Re: Metron vagrant up failing at ansible step - Amabari client

Rising Star

A few days back, Homebrew updated their Ansible version. This version exhibits this defect. Please verify you're running a version > 2.0.0.2 by running ansible -version. If you are, please install Ansible 2.0.0.2 using the following instructions:

  • Uninstall brew-installed Ansible -
    brew uninstall ansible
  • Install PIP (if not already installed)
  • brew install brew-pip
  • Install Ansible 2.0.0.2
  • pip install ansible==2.0.0.2
    
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Expert Contributor

I'm getting this error trying the vagrant install. This comes after running 'vagrant up' command.

TASK [ambari_config : Start All Hadoop Services node1] *************************
failed: [node1] (item=HDFS) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "HDFS", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1sgn1chrad41b1qw1kj03dd9kg;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/HDFS", "user": "admin"}
failed: [node1] (item=YARN) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "YARN", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1is6xyjxvpccqyba2f46le9sl;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/YARN", "user": "admin"}
failed: [node1] (item=MAPREDUCE2) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "MAPREDUCE2", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1nvb5mwkf1a0r19a051px2z1da;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/MAPREDUCE2", "user": "admin"}
failed: [node1] (item=ZOOKEEPER) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "ZOOKEEPER", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1t0e24juqq5be1oneug42xd9fy;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/ZOOKEEPER", "user": "admin"}
failed: [node1] (item=HBASE) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "HBASE", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1v10mm1sa85tj1jd0cxg53kmfr;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/HBASE", "user": "admin"}
failed: [node1] (item=STORM) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "STORM", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1xso3y6yntj86150i2ne8ixqdl;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/STORM", "user": "admin"}
failed: [node1] (item=KAFKA) => {"connection": "close", "content": "", "content_type": "text/plain;charset=ISO-8859-1", "failed": true, "item": "KAFKA", "msg": "Status code was not [200, 202]: HTTP Error 500: Server Error", "redirected": false, "server": "Jetty(8.1.17.v20150415)", "set_cookie": "AMBARISESSIONID=1e2nei5aurn69eq1lcnvfcnna;Path=/;HttpOnly", "status": 500, "url": "http://node1:8080/api/v1/clusters/metron_cluster/services/KAFKA", "user": "admin"}
	to retry, use: --limit @../../playbooks/metron_full_install.retry


PLAY RECAP *********************************************************************
node1                      : ok=38   changed=28   unreachable=0    failed=1


Ansible failed to complete successfully. Any error output should be
visible above. Please fix these errors and try again.
Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Expert Contributor

Breaking my comment prior since its over the character limit.

I checked my ansible version and it's using ansible 2.0.2. Uninstalled it and re-install 2.0.0.2 but getting this message.

$ pip install ansible==2.0.0.2
Requirement already satisfied (use --upgrade to upgrade): ansible==2.0.0.2 in /usr/local/lib/python2.7/site-packages
Requirement already satisfied (use --upgrade to upgrade): paramiko in /usr/local/lib/python2.7/site-packages (from ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): setuptools in /usr/local/lib/python2.7/site-packages (from ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): PyYAML in /usr/local/lib/python2.7/site-packages (from ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): pycrypto>=2.6 in /usr/local/lib/python2.7/site-packages (from ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): jinja2 in /usr/local/lib/python2.7/site-packages (from ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): pyasn1>=0.1.7 in /usr/local/lib/python2.7/site-packages (from paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): cryptography>=1.1 in /usr/local/lib/python2.7/site-packages (from paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): MarkupSafe in /usr/local/lib/python2.7/site-packages (from jinja2->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): enum34 in /usr/local/lib/python2.7/site-packages (from cryptography>=1.1->paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): ipaddress in /usr/local/lib/python2.7/site-packages (from cryptography>=1.1->paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): six>=1.4.1 in /usr/local/lib/python2.7/site-packages (from cryptography>=1.1->paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): idna>=2.0 in /usr/local/lib/python2.7/site-packages (from cryptography>=1.1->paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): cffi>=1.4.1 in /usr/local/lib/python2.7/site-packages (from cryptography>=1.1->paramiko->ansible==2.0.0.2)
Requirement already satisfied (use --upgrade to upgrade): pycparser in /usr/local/lib/python2.7/site-packages (from cffi>=1.4.1->cryptography>=1.1->paramiko->ansible==2.0.0.2)

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Expert Contributor

'pip uninstall ansible' did the trick to remove ansible 2.0.2. Successfully installed ansible 2.0.0.2. Will re-run 'vagrant up'.

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

New Contributor

I have the exact same issue. And it is not a proxy thing. I checked "node1:8080" in browser and It was not re-directed to google.

Highlighted

Re: Metron vagrant up failing at ansible step - Amabari client

Can anyone tell me how to solve the same issue?

Don't have an account?
Coming from Hortonworks? Activate your account here