Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
10-22-2020
06:36 AM
- last edited on
04-21-2026
04:24 AM
by
GrazittiAPI
Hi Community. I am getting an error starting Hive in Cloudera Manager, CDP7. The error reads, "Command failed to run because service Hive has an invalid configuration. Review and correct its configuration. First error: Missing service dependency for Hive: YARN".
How do I add the YARN dependency to an existing Hive service? Reinstalling Hive is not a really practical solution. Is there any way to add the dependency without reinstalling Hive?
Thanks!
Created 10-22-2020 07:08 AM
@hitachi_ben Go to CM > Hive > Configuration and then set MapReduce Service to YARN. For example below.
Let me know if this helps.
Created 10-22-2020 07:08 AM
@hitachi_ben Go to CM > Hive > Configuration and then set MapReduce Service to YARN. For example below.
Let me know if this helps.
Created 10-22-2020 12:38 PM
Thank you @GangWar, that fixed my issue.