Support Questions
Find answers, ask questions, and share your expertise

NIFI 1.13.* OpenJDK 14 upgrade

New Contributor

Hi,

 

Following Nifi's release its still using JDK 1.8 (even at release 1.15.3).

 

Is there any concern with trying to upgrade to OpenJDK 14 or even higher?

 

Thanks,

Ran

 

3 REPLIES 3

New Contributor

Reporting  my own tests:

Nifi-Version: 1.13.2

 

Upgrade to openjdk-17.0.1_linux-x64_bin.tar.gz 

Result: Nifi boot failure

 

Upgrade to openjdk-14.0.2_linux-x64_bin.tar.gz  

Result: Nifi boot success, had some exceptions from self created processor/controller. 

Master Collaborator

Hi, @rzilber ,

 

The latest release of Cloudera Flow Management, CFM 2.1.3, is tested and supported on Java 8 and 11, as listed here. This release contains NiFi and NiFi Registry 1.15.2.

 

I believe the upstream version of NiFi also currently supports only Java 8 and 11, as per release notes of version 1.10.0.

 

Cheers,

André

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

Thanks a lot,

Ran

; ;