Support Questions
Find answers, ask questions, and share your expertise

NIFI ERRORS

New Contributor

I am trying to install NIFI on AWS redhat linux EC2 instance (instance type t2.mciro) . Iwas able to start the instance using ./nifi.sh start. But after few minutes it stops with an error message "ERROR [NiFi logging handler] org.apache.nifi.StdErr OpenJDK 64-Bit Server VM warning: If the number of processors is expected to increase from one, then you should configure the number of parallel GC threads appropriately using -XX:ParallelGCThreads=N" .Please advise.

1 ACCEPTED SOLUTION

Accepted Solutions

@Kiran Dasari

t2.micro instance has only 1 vCPU core, but apparently RHEL OpenJDK assumes multi core machine by default. There's a github issue (not for NiFi, but Elasticsearch) suggesting use '-XX:-AssumeMP' to disable this assumption.

You can add JVM argument from <NIFI_HOME>/conf/bootstrap.conf. I tried this option with t2.micro. Without this, I got the same error as you reported. By adding the option NiFi proceeded startup further, but I also needed to reduce JVM heap size to have NiFi up and running. Changed bootstrap.conf as follows:

# JVM memory settings: from 512m to 256m
java.arg.2=-Xms256m
java.arg.3=-Xmx256m

# Add this to disable AssumeMP
# https://github.com/elastic/elasticsearch/issues/22245
java.arg.15=-XX:-AssumeMP

NiFi is running without issue for 30 minutes. I hope it's longer enough to confirm that the configuration can address your issue, too.

Thanks,

Koji

View solution in original post

1 REPLY 1

@Kiran Dasari

t2.micro instance has only 1 vCPU core, but apparently RHEL OpenJDK assumes multi core machine by default. There's a github issue (not for NiFi, but Elasticsearch) suggesting use '-XX:-AssumeMP' to disable this assumption.

You can add JVM argument from <NIFI_HOME>/conf/bootstrap.conf. I tried this option with t2.micro. Without this, I got the same error as you reported. By adding the option NiFi proceeded startup further, but I also needed to reduce JVM heap size to have NiFi up and running. Changed bootstrap.conf as follows:

# JVM memory settings: from 512m to 256m
java.arg.2=-Xms256m
java.arg.3=-Xmx256m

# Add this to disable AssumeMP
# https://github.com/elastic/elasticsearch/issues/22245
java.arg.15=-XX:-AssumeMP

NiFi is running without issue for 30 minutes. I hope it's longer enough to confirm that the configuration can address your issue, too.

Thanks,

Koji

View solution in original post