Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NIFI SSL Invalid Host Header error with port forwarding

avatar
Reader

Hi 

We have a nifi cluster of 3 nodes on which we are implementing SSL. All the configuration changes are done but when we access NIFI UI on our browser It throws this error - 

System Error
The request contained an invalid host header [127.0.0.1:<port>] in the request [/nifi/]. Check for request manipulation or third-party intercept.
Valid host headers are [empty] or:

Our port forwarding is like this - 

ssh -L  18443:<node-1-ip-adress>:8443 -i ~example.com
ssh -L  28443:<node-2-ip-adress>:8443 -i ~example.com
ssh -L  38443:<node-3-ip-adress>:8443 -i ~example.com

Then our ssh tunelling via putty is like this - 

L28443    127.0.0.1:18443
L48443    127.0.0.1:38443
L58444    127.0.0.1:58443

Any ideas how to resolve it ?

 

 

1 REPLY 1

avatar
Community Manager

@comviva Welcome to the Cloudera Community!

To help you get the best possible solution, I have tagged our NiFi experts @steven-matison @MattWho  who may be able to assist you further.

Please keep us updated on your post, and we hope you find a satisfactory solution to your query.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: