Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

NIFI UI not launching on HDP 3.0

New Contributor

I have installed HDP sandbox 3.0  and installed NIFI in the same cluster using HDF 3.4 mpack.

The problem i am facing is, NIFI  won't open from my host browser even though it is running.

"listening to Bootstrap on port 37693" also no errors whatsoever from nifi

 

I can curl to NIFI from within hdp (using a shell) but not from my host (windows).

Error from curl:

* Trying 127.0.0.1...
* Connected to localhost (127.0.0.1) port 9090 (#0)
> GET /nifi HTTP/1.1
> Host: localhost:9090
> User-Agent: curl/7.55.1
> Accept: */*
* Recv failure: Connection was aborted
* Closing connection 0
curl: (56) Recv failure: Connection was aborted

 

All other services are running fine. A few things i have tested but didn't work:

  1. Tried changing nifi.web.http.host to 0.0.0.0 or 127.0.0.1.
  2. Tried changing port from 9090 to some other but problem persist.
    (just to mention port is forwarding as well from VirtualBox)
  3. Disabled my windows firewall just to be sure it is not blocking that port.
  4. I have tried to apply many suggestions given in similar threads but nothing seems to work for me.

I am attaching my port configuration of VirtualBox and ports it is listening on in HDP.

 

image.pngimage.png

1 ACCEPTED SOLUTION

New Contributor

Thanks for your interest, the IP you suggested was actually the IP it was listening on before i tried changing it to

0.0.0.0 and 127.0.0.1.

 

And just while writing this comment, it got resolved by using one of the custom ports 60000.

 

Now my question is, why is it not working on port 9090? I have checked on windows port 9090 is bound by virtualbox as expected. Inside sandbox no process is running on port 9090. Don't have any firewall in HDP and firewall on my windows is disabled. 

View solution in original post

2 REPLIES 2

@Waleed_Malik have you tried setting Nifi to the IP in the port forwarding list:

 

172.18.0.2

 

Localhost, 0.0.0.0, 127.0.01 etc can cause issues with nifi web server attaching to the correct IP.   Even tho it may say its running on those ports,  you may not be able to get to them in the browser. 

 

 

If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  

 

Thanks,


Steven @ DFHZ

New Contributor

Thanks for your interest, the IP you suggested was actually the IP it was listening on before i tried changing it to

0.0.0.0 and 127.0.0.1.

 

And just while writing this comment, it got resolved by using one of the custom ports 60000.

 

Now my question is, why is it not working on port 9090? I have checked on windows port 9090 is bound by virtualbox as expected. Inside sandbox no process is running on port 9090. Don't have any firewall in HDP and firewall on my windows is disabled.