Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Need help in installing SAP HANA Vora in HDP 2.4

Solved Go to solution
Highlighted

Need help in installing SAP HANA Vora in HDP 2.4

Rising Star

Getting the below error

OSError: /lib/x86_64-linux-gnu/libc.so.6: cannot open shared object file: No such file or directory

Please find the error log for reference.

Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/vora-base/package/scripts/vora_base_client.py", line 39, in <module>
  VoraBase().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 219, in execute
  method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/vora-base/package/scripts/vora_base_client.py", line 26, in install
  'PLATFORM':params.platform
  File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 154, in __init__
  self.env.run()
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 158, in run
  self.run_action(resource, action)
  File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line 121, in run_action
  provider_action()
  File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py", line 238, in action_run
  tries=self.resource.tries, try_sleep=self.resource.try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 70, in inner
  result = function(command, **kwargs)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 92, in checked_call
  tries=tries, try_sleep=try_sleep)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 140, in _call_wrapper
  result = _call(command, **kwargs_copy)
  File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 291, in _call
  raise Fail(err_msg)
resource_management.core.exceptions.Fail: Execution of '/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/vora-base/package/scripts/control.py deploy_vora_base' returned 1. Traceback (most recent call last):
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/vora-base/package/scripts/control.py", line 32, in <module>
  from voralib import *
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.4/services/vora-base/package/lib/python/voralib.py", line 42, in <module>
  libc = ctypes.CDLL('/lib/x86_64-linux-gnu/libc.so.6')
  File "/usr/lib64/python2.7/ctypes/__init__.py", line 360, in __init__
  self._handle = _dlopen(self._name, mode)
OSError: /lib/x86_64-linux-gnu/libc.so.6: cannot open shared object file: No such file or directory
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Need help in installing SAP HANA Vora in HDP 2.4

Rising Star

@Joy @Neeraj Sabharwal

Thanks for all your help.

As per the update from SAP HANA Vora Developement team SAP HANA Vora is not supported by Centos 7.2.

Only upto RHEL 7.1 and SLES 11 not by Centos. Please refer the below screeshot.

4393-sap-hana-vora.png

View solution in original post

5 REPLIES 5
Highlighted

Re: Need help in installing SAP HANA Vora in HDP 2.4

Please check if you have the "" package installed on your OS?

install a newer version of glibc (the "libc6" package in Debian).

Example: (for Debian) sudo apt-get install libc6

(for CentOS/RHEL) yum install libc6

Highlighted

Re: Need help in installing SAP HANA Vora in HDP 2.4

Rising Star

@Joy

I am getting no package libc6 available error while trying to install.

Any suggestion on this would be much appreciated.

thank you

Highlighted

Re: Need help in installing SAP HANA Vora in HDP 2.4

@Raghu Ramamoorthi See this link and this

Look at this rpm repo http://rpmfind.net/linux/rpm2html/search.php?query=libc.so.6

You did not mention the OS

Error:

libc = ctypes.CDLL('/lib/x86_64-linux-gnu/libc.so.6')File"/usr/lib64/python2.7/ctypes/__init__.py", line 360,in __init__self._handle = _dlopen(self._name, mode)

OSError:/lib/x86_64-linux-gnu/libc.so.6: cannot open shared object file:No such file or directory

This is from my env

[root@amtest01 ~]# rpm -qa | grep libc

libcom_err-1.41.12-22.el6.x86_64

libcgroup-0.40.rc1-5.el6_5.1.x86_64

libcap-2.16-5.5.el6.x86_64

glibc-common-2.12-1.166.el6_7.7.x86_64

glibc-devel-2.12-1.166.el6_7.7.x86_64

libcom_err-1.41.12-22.el6.i686

glibc-2.12-1.166.el6_7.7.i686

libcap-ng-0.6.4-3.el6_0.1.x86_64

glibc-2.12-1.166.el6_7.7.x86_64

glibc-headers-2.12-1.166.el6_7.7.x86_64

libcurl-7.19.7-37.el6_5.3.x86_64

[root@amtest01 ~]# find / -name libc.so.6

/lib/libc.so.6

/lib/i686/nosegneg/libc.so.6

/lib64/libc.so.6

/root/initrd/lib64/libc.so.6

[root@amtest01 ~]# uname -a

Linux amtest01 2.6.32-431.20.3.el6.x86_64 #1 SMP Thu Jun 19 21:14:45 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

[root@amtest01 ~]# cat /etc/redhat-release

CentOS release 6.5 (Final)

[root@amtest01 ~]#

Re: Need help in installing SAP HANA Vora in HDP 2.4

Rising Star
@Neeraj Sabharwal

The below is the information i got from my laptop.

[root@hdpclient1 ~]# rpm -qa | grep libc libchewing-0.3.4-6.el7.x86_64 libcdio-0.92-1.el7.x86_64 glibc-headers-2.17-106.el7_2.6.x86_64 libconfig-1.4.9-5.el7.x86_64 libcanberra-gtk3-0.30-5.el7.x86_64 compat-libcolord1-1.0.4-1.el7.x86_64 libcap-2.22-8.el7.x86_64 glibc-2.17-106.el7_2.6.x86_64 libcroco-0.6.8-5.el7.x86_64 libcgroup-tools-0.41-8.el7.x86_64 libchamplain-gtk-0.12.4-5.el7.x86_64 libcgroup-0.41-8.el7.x86_64 compat-libcogl-pango12-1.14.0-3.el7.x86_64 libcom_err-1.42.9-7.el7.x86_64 libcanberra-0.30-5.el7.x86_64 compat-glibc-headers-2.12-4.el7.centos.x86_64 libcurl-7.29.0-25.el7.centos.x86_64 libchamplain-0.12.4-5.el7.x86_64 libcdio-paranoia-10.2+0.90-11.el7.x86_64 compat-libcap1-1.10-7.el7.x86_64 glibc-devel-2.17-106.el7_2.6.x86_64 libcacard-1.5.3-105.el7_2.3.x86_64 compat-libcogl12-1.14.0-3.el7.x86_64 libcanberra-gtk2-0.30-5.el7.x86_64 glibc-common-2.17-106.el7_2.6.x86_64 libcollection-0.6.2-25.el7.x86_64 libcap-ng-0.7.5-4.el7.x86_64 libcmis-0.4.1-5.el7.x86_64 libcdr-0.1.1-1.el7.x86_64 compat-glibc-2.12-4.el7.centos.x86_64 [root@hdpclient1 ~]# find / -name libc.so.6 /usr/lib64/libc.so.6 [root@hdpclient1 ~]# uname -a Linux hdpclient1.sierra.com 3.10.0-327.13.1.el7.x86_64 #1 SMP Thu Mar 31 16:04:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux [root@hdpclient1 ~]# cat /etc/redhat-release CentOS Linux release 7.2.1511 (Core)

Highlighted

Re: Need help in installing SAP HANA Vora in HDP 2.4

Rising Star

@Joy @Neeraj Sabharwal

Thanks for all your help.

As per the update from SAP HANA Vora Developement team SAP HANA Vora is not supported by Centos 7.2.

Only upto RHEL 7.1 and SLES 11 not by Centos. Please refer the below screeshot.

4393-sap-hana-vora.png

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here