Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 01-10-2019 08:51 PM
Dear @Jay Kumar SenSharma
As per your suggested video link https://www.youtube.com/watch?v=wHaVBoLwzwU i have done all network setup ...and installation of ambari server and ambari-agent...successfully by local repo ....-
When i adding only master , there is error to register .....
see in ambari-agent log file .....
INFO 2019-01-10 08:35:21,750 main.py:145 - loglevel=logging.INFO
INFO 2019-01-10 08:35:21,751 main.py:145 - loglevel=logging.INFO
INFO 2019-01-10 08:35:21,751 main.py:145 - loglevel=logging.INFO
INFO 2019-01-10 08:35:21,754 DataCleaner.py:39 - Data cleanup thread started
INFO 2019-01-10 08:35:21,756 DataCleaner.py:120 - Data cleanup started
INFO 2019-01-10 08:35:21,758 DataCleaner.py:122 - Data cleanup finished
INFO 2019-01-10 08:35:21,820 PingPortListener.py:50 - Ping port listener started on port: 8670
INFO 2019-01-10 08:35:21,823 main.py:437 - Connecting to Ambari server at https://master.alethe.com:8440 (192.168.1.191)
INFO 2019-01-10 08:35:21,824 NetUtil.py:70 - Connecting to https://master.alethe.com:8440/ca
ERROR 2019-01-10 08:35:21,871 NetUtil.py:96 - [Errno 8] _ssl.c:504: EOF occurred in violation of protocol
ERROR 2019-01-10 08:35:21,871 NetUtil.py:97 - SSLError: Failed to connect. Please check openssl library versions.
Refer to: https://bugzilla.redhat.com/show_bug.cgi?id=1022468 for more details.
WARNING 2019-01-10 08:35:21,871 NetUtil.py:124 - Server at https://master.alethe.com:8440 is not reachable, sleeping for 10 seconds...
Also i have find the answer in below link
By adding below config in [security] section of
but in my System /etc/python is not available , how to find /python/cert-verificatin.cfg to change the verify=disable
My Operating System is Centos 7
HDP2.6.3 AND AMBARI2.6
Created 01-10-2019 08:56 PM
As you are getting the following error:
NetUtil.py:96 - [Errno 8] _ssl.c:504: EOF occurred in violation of protocol
.
To solve this problem simply configure the Ambari Agent to use TLSv1.2 when communicating with the Ambari Server by editing each Ambari Agent’s /etc/ambari-agent/conf/ambari-agent.ini file and adding the following configuration property to the security section:
[security] force_https_protocol=PROTOCOL_TLSv1_2
.
Refer to a detailed explanation on this flag in the following article: https://community.hortonworks.com/articles/188269/javapython-updates-and-ambari-agent-tls-settings.h...
.
Regarding your query "how to find /python/cert-verificatin.cfg" ?
There is no need to set the verify=disable for this issue . However if you want to do it then you will have to manually create the mentioned file with the verify=disable.
Created 01-10-2019 08:56 PM
As you are getting the following error:
NetUtil.py:96 - [Errno 8] _ssl.c:504: EOF occurred in violation of protocol
.
To solve this problem simply configure the Ambari Agent to use TLSv1.2 when communicating with the Ambari Server by editing each Ambari Agent’s /etc/ambari-agent/conf/ambari-agent.ini file and adding the following configuration property to the security section:
[security] force_https_protocol=PROTOCOL_TLSv1_2
.
Refer to a detailed explanation on this flag in the following article: https://community.hortonworks.com/articles/188269/javapython-updates-and-ambari-agent-tls-settings.h...
.
Regarding your query "how to find /python/cert-verificatin.cfg" ?
There is no need to set the verify=disable for this issue . However if you want to do it then you will have to manually create the mentioned file with the verify=disable.