Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NiFi ConsumeJMS processor error(Solace eventBroker)

avatar
Frequent Visitor

I am trying to integrate NIFI with Solace event broker and have created JMSConnectionFactoryProvidor service, which is enabled and running. However my JMSConsume processor gives this error - 

ConsumeJMS failed to process session due to Host not specified;

Below are the configs for my FactoryService and processor:

amitjha_0-1737530993344.pngamitjha_1-1737531000505.png

What am I missing in the configuration?

Thanks.

3 REPLIES 3

avatar
Master Mentor

@amitjha 

Providing the full stack trace from the nifi-app.log may help here in identifying the issue.

Is the controller service enabled and valid?
any other exceptions in the logs related to either the consumeJMS processor or the JMSConnectionFactoryProvider controller service?

The connectionFactory will on attempt to create the connection once first referencing component request a connection.  The exception eludes to and issue there, but full stack trace may help identify exactly what went wrong.

Have you tried this tutorial from Solace:
https://solace.com/integration-hub/nifi/

Other observations:

  • Keep in mind that you are using an HDF release that is going on 8 years old. 
  • I recommend not adding outside jars directly to the NiFi lib directory.  Create a directory outside of NiFi's base directory and add your custom jars there.  Just make sure the NiFi service user can access that directory and owns the jars.

Thanks,
Matt

avatar
Frequent Visitor

Thanks for the prompt response. We are working to get the stack-trace logs and would get back to you.

Thanks,

Amit.

avatar
Frequent Visitor

Hi Matt,

This is the error, we receive in the log:

amitjha_0-1738061335893.png

Thanks,

Amit.