Support Questions

Find answers, ask questions, and share your expertise

NiFi InvokeHTTP -Is there DNS caching or something that would interfere with GSLB failover?

Explorer

Version: NiFi 1.11.x

 

Noticed a behavior where for this version of NiFi, when the remote url is a GSLB, it doesn't recognize when a host is removed from a GSLB until the processor is stopped. Any idea why? Any ideas for a solution?

5 REPLIES 5

Explorer

Kind of an update: A jank workaround was to force the Connection to close, but it's not the best solution. Looking to see why the client is ignoring the DNS TTL.

Master Collaborator

@Eric_B ,

 

This is a behaviour inherited from Java. Java caches DNS resolved names internally.

You can adjust the cache TTL value by specifying the corresponding Java property during NiFi startup.

 

Please see a description of the property here: https://docs.aws.amazon.com/sdk-for-java/v1/developer-guide/java-dg-jvm-ttl.html

 

Cheers,

André

 

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

Hi @araujo ! That seems to be cause, but I'm a bit confused on how I would set it up. I attempted to both set it in the bootstrap as well as via the jre, but still nothing seems to be working. 

Master Collaborator

Can you share your settings?

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Explorer

I've attempt to set the above in the java.security file and in the bootstrap I set the runtime variables as
java.arg.20=-Djava.security.networkaddress.cache.ttl=60
java.arg.21=-Dsun.net.inetaddr.ttl=60

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.