Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NiFi ListenHTTP Failed to bind to 0.0.0.0

avatar
Rising Star

Hello,

while attempting to start ListenHTTP (port=10000) on a fresh cluster, I obtain the following error. Do you know what to change to get it work?

 

ListenHTTP[id=6222ab5d-0177-1000-ffff-ffffaeaba266]
Failed to properly initialize Processor. If still scheduled to run, NiFi will attempt to initialize and run the Processor again after the 'Administrative Yield Duration' has elapsed.
Failure is due to java.io.IOException: Failed to bind to 0.0.0.0/0.0.0.0:10000: java.io.IOException: Failed to bind to 0.0.0.0/0.0.0.0:10000


Cloudera Flow Management (CFM) 2.0.4.0
1.11.4.2.0.4.0-80 built 09/27/2020 09:52:49 CEST
Tagged nifi-1.11.4-RC1

 

Best regards

Jaro

1 ACCEPTED SOLUTION

avatar
Rising Star

Stupid me, the port was already occupied

View solution in original post

1 REPLY 1

avatar
Rising Star

Stupid me, the port was already occupied