Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

NiFi Registry - Initial Admin Identity is not working - Not able to create bucket

Highlighted

NiFi Registry - Initial Admin Identity is not working - Not able to create bucket

New Contributor

I tried to configure LDAP with NiFi and NiFi Registry. And LDAP authentication is working fine in both the services.

Here, the thing is I am not able to get into NiFi Registry Administration Console.


Below are the configurations made to NiFi Registry Service:


SSL

For both NiFi and NiFi Registry, we are using a host-specific self-signed certificate. And both services refer to the same Java Keystores.


Initial Admin Identity

CN=admin, OU=Hadoop, OU=Accounts-Service, DC=Domain, DC=com


NiFi Identities

<property name="NiFi Identity 1">CN=node1.domain.com, OU=IT, O=COMPANY, L=Area, ST=State, C=US</property>
<property name="NiFi Identity 2">CN=node2.domain.com, OU=IT, O=COMPANY, L=Area, ST=State, C=US</property>


authorizers.xml

<userGroupProvider>
    <identifier>file-user-group-provider</identifier>
    <class>org.apache.nifi.registry.security.authorization.file.FileUserGroupProvider</class>
    <property name="Users File">{{nifi_registry_internal_config_dir}}/users.xml</property>
    <property name="Initial User Identity 1">CN=node1.domain.com, OU=IT, O=COMPANY, L=Area, ST=State, C=US</property>
    <property name="Initial User Identity 2">CN=node2.domain.com, OU=IT, O=COMPANY, L=Area, ST=State, C=US</property>
    <property name="Initial User Identity 3">CN=admin, OU=Hadoop, OU=Accounts-Service, DC=Domain, DC=com</property>
    {{nifi_registry_ssl_config_content | replace("NiFi","Initial User")}}
</userGroupProvider>


<accessPolicyProvider>
    <identifier>file-access-policy-provider</identifier>
    <class>org.apache.nifi.registry.security.authorization.file.FileAccessPolicyProvider</class>
    <property name="User Group Provider">file-user-group-provider</property>
    <property name="Authorizations File">{{nifi_registry_internal_config_dir}}/authorizations.xml</property>
    <property name="Initial Admin Identity">CN=admin, OU=Hadoop, OU=Accounts-Service, DC=Domain, DC=com</property>
    {{nifi_registry_ssl_config_content}}
</accessPolicyProvider>


Please look below screenshot for the reference.

109452-nifi-registry-admin-login.png


Kindly help me to resolve this issue.