Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NiFi - StandardHttpContextMap is causing OutOfMemoryError and UI won't load

avatar
Contributor

That pretty much sums it up. We had a database server go down over the weekend, and I have a suspicion that things got backed up, but I can't get to the UI to try to unravel it. I have tried setting autoResumeState to false and setting everything in flow.xml.gz to "Disabled", but the UI still won't come up because of this error. Unfortunately, all of this is in an isolated environment, so sharing full logs is not impossible but very, very difficult. This vm has 23GB of RAM and Xms=4096m and Xmx=8192m. niagarafiles-community-11.6.3

1 ACCEPTED SOLUTION

avatar
Contributor

I doubled Xmx to 16384 and the UI came up and rather large backlog of files has begun to flow.

View solution in original post

2 REPLIES 2

avatar
Contributor

Looking at the log some more, I should add, the initial "error" includes "GC overhead limit exceeded", which I have learned GC = garbage collection.

avatar
Contributor

I doubled Xmx to 16384 and the UI came up and rather large backlog of files has begun to flow.