Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!


New Contributor

Every thing is running fine But the Nifi UI is not working. I have tried everything that are given below:.

  • selinux is disabled
  • I look into the files: nifi-app.log and nifi-bootstarp.log i didn't get any error. Everything is fine
  • i have changed the port 8080 to 8075 from file
  • /bin/ status command i got the response: 2017-06-11 19:02:30,402 INFO [main] org.apache.nifi.bootstrap.Command Apache NiFi is currently running, listening to Bootstrap on port 45613, PID=8707
  • i have tried this in both browser chrome and IE but got the same response
  • i have restart Nifi a number of times but it doesn't help me.

Please can anyone help me to resolve my issue.


Super Mentor

@Ahmad Mehr

When you start NiFi, the UI does not become available until the application has completed loading.

/bin/ status

The above command simply shows that the application is running, but does not indicate the UI is available yet.

To verify that NiFi has completed the startup process and the UI is now available, you will need to look in the nifi-app.log for the following lines:

2017-06-12 09:16:16,029 INFO [main] org.apache.nifi.web.server.JettyServer NiFi has started. The UI is available at the following URLs:
2017-06-12 09:16:16,029 INFO [main] org.apache.nifi.web.server.JettyServer http://<HOSTNAME>:8075/nifi
2017-06-12 09:16:16,031 INFO [main] org.apache.nifi.BootstrapListener Successfully initiated communication with Bootstrap
2017-06-12 09:16:16,031 INFO [main] org.apache.nifi.NiFi Controller initialization took 14617467433 nanoseconds.

Until you see these log lines, the UI will not be accessible.

You can also run the following linux command to see if "something" is listening on port 8075 yet:

netstat -ant|grep LISTEN|grep 8075

Thank you,


Cloudera Employee

The problem may be is the host the NiFi web server listens on. Try to change the following parameter in Ambari then restart NiFi and wait a minute:



New Contributor

Sometimes nifi UI is not showing because nifi is not running correctly even if it shows that it is launched, i suggest to check your java_home parameter in the nifi/bin/ file and see if the path and/or value of jdk corresponds to yours. (note: the java_home parameter in this file is not editabe).