Support Questions
Find answers, ask questions, and share your expertise

NiFi listener processor not responding though UI is up

New Contributor

NiFi listener processor not responding though UI is up.

The CPU, threads, Memory all are getting used almost nothing.

 

No OOM also Can someone please give some pointers what can be done so the http listener processor keeps running

 

3 REPLIES 3

Master Collaborator

Hi, @chitrarthasur ,

 

How are you testing the connection to the listener processor and what are the results of this test?

 

Cheers,

André

 

--

Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.

New Contributor

@araujo 

This is whats happening. So telnet is working fine but the curl is not working. The request does not hit the listener.
However, after nifi restart it works, i.e it hits the listener. So path rules are also correct.

chitrarthasur_0-1648614429735.png

chitrarthasur_2-1648614637332.png

 

 

Master Collaborator

@chitrarthasur ,

 

The processor that you're using is not the ListenHTTP processor, but the HandleHttpRequest, correct?

When you use HandleHttpRequest, you must always connect that processor to a HandleHttpResponse processor so that NiFi can send a response back to the client. With this you can ingest the content of the request, process it in NiFi and send a response according to the results of your processing.

 

If your only requirement is to ingest the content of the HTTP request, you should use a ListenHTTP instead.

 

Cheers,

André

 

--
Was your question answered? Please take some time to click on "Accept as Solution" below this post.
If you find a reply useful, say thanks by clicking on the thumbs up button.
; ;