Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

NiFi port 9090 not getting forwarded in HDP-sandbox 2.6.5 running in vmware


NiFi port 9090 not getting forwarded in HDP-sandbox 2.6.5 running in vmware

New Contributor


I installed HDP sandbox 2.6.5 and added Nifi to it by adding mpack in ambari. Installation was successful with service check errors I but could not connect to Nifi on port 9090. I shut down zeppelin and assigned port 9995 as Nifi HTTP port in Configs. On restarting, Nifi UI was accessible on port 9995 but when I tried to configure a processor after adding it, it gave an error "Unable to communicate with NiFi".

I uninstalled and reinstalled it and changed the http port to 9995 during installation. This time also service checks during installation failed giving socket connect error.

Another strange thing that I noticed is that both 9090 and 9995 are getting forwarded in and can be seen in the port list when I do docker container ls. Still, when I try to connect to these ports from VM Host, for 9995 and other primarily HDP ports I get nginx error- "Bad Gateway" if the service is not up. But for 9090, it displays a plain browser connection refused page. I tried to forward new ports by regenerating and restarting the sandbox-hdp and sandbox-proxy containers but for all new ports, the behavior is same as for 9090.

Please help.

Don't have an account?
Coming from Hortonworks? Activate your account here