Support Questions
Find answers, ask questions, and share your expertise

[NiFi] response time slow on a cluster with 8 nodes

[NiFi] response time slow on a cluster with 8 nodes

Explorer

Hi,

we are actually working on a PoC with 8 nodes (HP BL460c Blades, 24 Cores, 44GB RAM) in a NiFi 1.5.0 cluster. Our configuration has about 170 processors and all of them are stopped. Even in the stopped state, we are constanstly getting the messages below for all nodes, not only for the primary node.

Response time from nifi2-07.xyz.ch:8080 was slow for each of the last 3 requests made. To see more information about timing, enable DEBUG logging for org.apache.nifi.cluster.coordination.http.replication.ThreadPoolRequestReplicator

If you are on the root canvas, you feel that it takes a few seconds until it response after a refresh. We have already tuned the parameters below, but without any luck. After start restart of NiFi it is fine for a few minutes, but then the messages return.

nifi.cluster.protocol.heartbeat.interval=15 sec
nifi.cluster.node.protocol.threads=40
nifi.cluster.node.protocol.max.threads=80
nifi.cluster.node.connection.timeout=60 sec
nifi.cluster.node.read.timeout=60 sec

Our root canvas is quite big and has a lot of Process Groups. Please check the Attachment. Any suggestion what we can do to solve the issue? Do we have to many Elements in one view, especially on the root view?

Cheers

62519-root-canvas.png

1 REPLY 1
Highlighted

Re: [NiFi] response time slow on a cluster with 8 nodes

Explorer

I figured it out. The culprit were at least 2 custom processors. As soon as I delete them from the configuration/webgui, the CPU load goes down to more or less 0% and the error messages are gone. Will verify with the developper why that happens.

Check out my Jira Ticket for more Information:

https://issues.apache.org/jira/projects/NIFI/issues/NIFI-4905