Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

NiFi suddently stopped working and not able to restart it

avatar
New Contributor

Hi,

 

I'm pretty new to NiFi and don't have much experience with it, so it's the reason I'm here.

 

Yesterday, NiFi was running smoothly and for some reason it stopped working. Every time I tried to start : ./nifi.sh start or any other command it showed me "killed". Later on, I found that java was killed by OOM. Fixed this by restarting server, but it won't start. In the "nifi-bootstrap.log" I found that it's getting shut down due to this error:
Capture.PNG
I haven't installed any packages, so don't know why it's giving me this error.

Setup:
Ubuntu 20
openjdk 11.0.11
nifi 1.13.2
Connector: mysql-connector-java-8.0.25.jar

What should I check? How to fix this error and start nifi?

Thanks in advance.

1 ACCEPTED SOLUTION

avatar
Master Collaborator

Can you take a back of up existing flow.xml.gz and remove the flow.xml.gz.  Once you removed the flow.xml.gz try restarting the nifi from the backend. 

View solution in original post

3 REPLIES 3

avatar
Master Collaborator

Hello,

 

Have you checked the nifi app logs?  What errors you see in nif-app.log. 

avatar
New Contributor

ERROR [main] o.a.n.c.serialization.FlowFromDOMFactory There was a problem decrypting a sensitive flow configuration value. Check that the nifi.sensitive.props.key value in nifi.properties matches the value used to encrypt the flow.xml.gz file

Was following this guide : https://community.cloudera.com/t5/Support-Questions/Failed-to-connect-node-to-cluster-because-local-...

But stuck witht finding config.zip file

avatar
Master Collaborator

Can you take a back of up existing flow.xml.gz and remove the flow.xml.gz.  Once you removed the flow.xml.gz try restarting the nifi from the backend.