Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Nifi run cmd script (.bat)

New Contributor

Hello all,


I have tried several configurations to run batch scrip (cmd) in Windows following a schedule using nifi. I think this configuration should work using ExecuteProcess processor but no....

If I run ".bat" file outside nifi it works fine.

Could someone help me? I have googled without results.


Thanks in advance.




@alex15   I suspect the issue you have is that nifi use is not able to execute the script.

Make sure the user ownership of the file is correct, also confirm read/write permissions.  In unix/linux these are chown and chmod.   



If this answer resolves your issue or allows you to move forward, please choose to ACCEPT this solution and close this topic. If you have further dialogue on this topic please comment here or feel free to private message me. If you have new questions related to your Use Case please create separate topic and feel free to tag me in your post.  




Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.