Support Questions
Find answers, ask questions, and share your expertise

Node Manager stops after few moment

Solved Go to solution

Node Manager stops after few moment

New Contributor

Getting the below error

ERROR org.apache.hadoop.yarn.server.nodemanager.NodeStatusUpdaterImpl: Unexpected error starting NodeStatusUpdater
org.apache.hadoop.yarn.exceptions.YarnRuntimeException: Recieved SHUTDOWN signal from Resourcemanager ,Registration of NodeManager failed, Message from ResourceManager: NodeManager from ubuntu-VirtualBox doesn't satisfy minimum allocations, Sending SHUTDOWN signal to the NodeManager.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Node Manager stops after few moment

@Subhas Gupta

Looks like you don't have enough resources. Do check the resource allocations and reduce them if you can.

View solution in original post

4 REPLIES 4

Re: Node Manager stops after few moment

@Subhas Gupta

Looks like you don't have enough resources. Do check the resource allocations and reduce them if you can.

View solution in original post

Re: Node Manager stops after few moment

New Contributor

@Sandeep Nemuri

I am a beginer and just installed the hadoop and testing jps command first time then seeing that all 6 resources are running and hit the jps second time then seeing node manger is missing.

could you please explain me in detail so that i can solve this issue.. Thanks

Re: Node Manager stops after few moment

Expert Contributor

As sandeep said its issue to resource as you have updated same in error "NodeManager from ubuntu-VirtualBox doesn't satisfy minimum allocations,".

To get some understanding read below, definitely you some idea.

https://mapr.com/blog/best-practices-yarn-resource-management/

Re: Node Manager stops after few moment

New Contributor

Check the heap assigned for the node manager

 

in the hadoop/etc/hadoop/yarn-env.sh define the heap for node manager

 

JAVA=$JAVA_HOME/bin/java
JAVA_HEAP_MAX=-Xmx256m

# For setting YARN specific HEAP sizes please use this
# Parameter and set appropriately
YARN_HEAPSIZE=256

After that, you can configure the resources in yarn-site.xml

<configuration>
<property>
        <name>yarn.nodemanager.aux-services</name>
        <value>mapreduce_shuffle</value>
    </property>
<property>
        <name>yarn.scheduler.minimum-allocation-mb</name>
        <value>2000</value>
    </property>
<property>
        <name>yarn.scheduler.minimum-allocation-vcores</name>
        <value>1</value>
    </property>
<property>
        <name>yarn.nodemanager.resource.memory-mb</name>
        <value>2000</value>
    </property>
<property>
        <name>yarn.nodemanager.resource.cpu-vcores</name>
        <value>1</value>
    </property>
</configuration>

 

please like and confirm if it helps

 

Thanks

Ashish