Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Not Able to start hive metastore

Solved Go to solution
Highlighted

Not Able to start hive metastore

Expert Contributor
Resource_management.core.exceptions.Fail: Execution of 'export HIVE_CONF_DIR=/usr/hdp/current/hive-metastore/conf/conf.server ; /usr/hdp/current/hive-metastore/bin/schematool -initSchema -dbType postgres -userName hive -passWord [PROTECTED]' returned 254. /etc/profile: fork: retry: Resource temporarily unavailable
/etc/profile: fork: retry: Resource temporarily unavailable
/etc/profile: fork: retry: Resource temporarily unavailable
/etc/profile: fork: retry: Resource temporarily unavailable
/etc/profile: fork: Resource temporarily unavailable
/etc/profile: fork: retry: Resource temporarily unavailable 

/etc/profile: fork: retry: Resource temporarily unavailable

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Not Able to start hive metastore

Expert Contributor

Thanks Everyone,

I resolved the issue by increasing the /etc/security/limits.d/hive.conf . Everything went fine.

View solution in original post

4 REPLIES 4
Highlighted

Re: Not Able to start hive metastore

Guru

you're apparently running out of file descriptors, try to adjust your ulimit accordingly

Highlighted

Re: Not Able to start hive metastore

Expert Contributor

su hive su: cannot set user id: Resource temporarily unavailable

Re: Not Able to start hive metastore

Rising Star

@chennuri gouri shankar

Main issue could be :

  • The system was not able to create new process(es), because of the limits set for nproc in /etc/security/limits.conf file.
  • Increase the value of "nproc" parameter for user or all user's in /etc/security/limits.d/90-nproc.conf example of /etc/security/limits.d/90-nproc.conf file.
  • <code><user>       -          nproc     2048      <<<----[ Only for "<user>" user ]

Please use this link to debug for redhat linux flavours:

https://access.redhat.com/solutions/543503

Other thing you can check is the user limit in creating processes.

Check with : ulimit -a. (TO check Limits in your shell)

Esp check for 'ulimit -u' max user processes,

Highlighted

Re: Not Able to start hive metastore

Expert Contributor

Thanks Everyone,

I resolved the issue by increasing the /etc/security/limits.d/hive.conf . Everything went fine.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here