Support Questions
Find answers, ask questions, and share your expertise

Oozie Action status is running but WF Job status is SUCCEEDED

Oozie Action status is running but WF Job status is SUCCEEDED

Super Guru

Oozie experts!

Has anyone seen this behavior before? where Oozie WF is SUCCEEDED however action status is still RUNNING.

Below is an error:

2016-11-04 19:48:07,740 INFO CallbackServlet:520 - SERVER[XXX] USER[-] GROUP[-] TOKEN[-] APP[-] JOB[XYZ-oozie-oozi-W] ACTION[XYZ-oozi e-oozi-W@actionname] callback for action [XYZ-oozie-oozi-W@actionname] 2016-11-04 19:48:07,757 WARN ActionCheckXCommand:523 - SERVER[YYY] USER[XYZ] GROUP[-] TOKEN[] APP[APPNAME] JOB[XYZ-oozie-oozi-W] ACTION[XYZ-oozie-oozi-W@actionname] E0818: Action [XZY-oozie-oozi-W@actionname] status is running but WF Job [XYZ-oozie-oozi-W] status is [SUCCEEDED]. Expected status is RUNNING or SUSPENDED., Error Code: E0818 

Is this a known issue? I'm using Postgresql as backend database. No other errors in /var/log/oozie.log

This was observed only one time.

3 REPLIES 3

Re: Oozie Action status is running but WF Job status is SUCCEEDED

Super Guru

Re: Oozie Action status is running but WF Job status is SUCCEEDED

Expert Contributor

@Kuldeep Kulkarni

Is the launched Hadoop job from action also running, have you checked that this as well.

Can you attach the oozie.log to analyze this behaviour.

Re: Oozie Action status is running but WF Job status is SUCCEEDED

Super Guru

Thanks @peeyush for the reply.

Yes Hadoop job was already completed. I will email you the logs and more details.