Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

PIG script stays in running status

Solved Go to solution

PIG script stays in running status

New Contributor

I am trying the hello world tutorial in sandbox and step no 3.4. The PIG scripts is not getting completed, always stays in running status. An empty table riskfactor is getting created in Hive. How do I know what's going wrong? Where to check and fix the issue?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PIG script stays in running status

@souvik majumdar

Launch Ambari

Click Yarn and quick links , click Resource Manager UI

832-screen-shot-2015-12-15-at-62608-am.png

833-screen-shot-2015-12-15-at-62649-am.png

6 REPLIES 6

Re: PIG script stays in running status

@souvik majumdar

Launch Ambari

Click Yarn and quick links , click Resource Manager UI

832-screen-shot-2015-12-15-at-62608-am.png

833-screen-shot-2015-12-15-at-62649-am.png

Re: PIG script stays in running status

New Contributor

Hi Neeraj,

Thanks. Ifixed the issue. have I just went ahead and started the Hbase service and then it worked.

Re: PIG script stays in running status

Thanks @souvik majumdar. Just curious on how HBase start fixed the Pig job issue.

Re: PIG script stays in running status

New Contributor

Well What I mean to say I could see many servers were stopped and I started them, one of them was HBase. not sure this one or some other restart solved the issue. What was your recommendation? I will follow that next time when I see this issue.

Re: PIG script stays in running status

@souvik majumdar I don't think starting HBase was the fix. There is a chance that HDFS or Yarn was down and you restarted those services. If issue is resolved then I believe we can close this thread.

Re: PIG script stays in running status

New Contributor

yes, we can close this. thank you once again.