Support Questions

Find answers, ask questions, and share your expertise

PcapCli Unable to write



I'm using Metron 0.4.2 to run From reading the documents, the default output directory is /tmp if -bop is not specified. I tried using default as well as specifying -bop, but I always get Permission denied. If it's trying to write to /tmp, then any user has permission to write. I also checked hdfs /tmp and that's also a true statement that any user can write.

I try to dig into the code, but it's not obvious to me where is it attempting to write the output file. I tried to run as hdfs/metron/storm user, but all ends with the same error. Thank you in advance for your help.

18/02/05 13:37:29 ERROR query.PcapCli: Unable to write pcap-data-201802051835-9b5f3448c9914581a78f705e4c3b4de2+0001.pcap (Permission denied)
at Method)at
at org.apache.metron.pcap.query.ResultsWriter.write(
at org.apache.metron.pcap.query.PcapCli.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(
at sun.reflect.DelegatingMethodAccessorImpl.invoke(
at java.lang.reflect.Method.invoke(
at org.apache.hadoop.util.RunJar.main(


I figured this out. If it ever help anyone; it writes to whatever the current directory you're in. It's not true that the default is /tmp directory; documentation might be outdated.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.